You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, January 25th 2019, 5:45pm

Oculus not mirroring on chrome

Hi there,

thank you for all your work.

I was using krpano together with Oculus and Chromium-WebVR.
Due to an update to Oculus firmware I had to pass from Chromium-WebVR to the new version of Chrome(71) that supports WebVR and new Oculus.

Sadly, doing this I lost the possibility to mirror the Oculus to the screen while i'm using it - despite having the "fullscreen_mirroring" to true.

I also get two types of errors:

Source code

1
[Deprecation] VREyeParameters.offset is deprecated. Please use view matrices provided by VRFrameData instead.

and

Source code

1
2
getFrameData must be called within a VRDisplay.requestAnimationFrame callback.
submitFrame must be called within a VRDisplay.requestAnimationFrame callback.

I honestly don't know if this has anything to do with the mirroring or not as the code is uglified and it's quite difficult to read, but looking at some example(mainly the immersive-web samples, as they are the one developing the WebXR apis) looks like it may be involved.

Any possibility this will be resolved in the next version?
If not, is there a way for me to load the plugin (at least as plain text instead of encoded) so that i can fix it myself?

Thank you,
S.

2

Wednesday, January 30th 2019, 2:53pm

Hi,

The warnings/errors itself are not related and will be removed in the next release (for the moment they can be ignored and have no effect).

The new Chrome versions have a special need to provide mirroring - the WebGL 'preserveDrawingBuffer' setting need to be enabled.

To enable it in krpano, add this setting in the html file this way:

Source code

1
embedpano({..., webglsettings:{preserveDrawingBuffer:true}});


See also here for more:
https://krpano.com/docu/html/#webglsettings

Best regards,
Klaus

3

Thursday, January 31st 2019, 7:57pm

Oh, I see!

I guess the old chrome was creating a context for webvr mode with the drawing buffer preserved while the new one has to be explicitly told so?

Anyway thank you very much for your help!