Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 9. Februar 2019, 16:35

Added custom buttons, Scene doesnt KeepView

I put together a few extra buttons to load some new panos.
I have loadscene_flags="MERGE|KEEPVIEW|KEEPMOVING" normally on to keep position when navaigating through the thumbnails.
Unfotruntely when I added some new buttons to navigate, it doesnt hold.

Not sure if I'm missing something in setting up buttons?
Any thoughts would be appreciated

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
<layer name="buttons" keep="true" visible="true" url="%SWFPATH%/plugins/textfield.swf" align="right" width="252" height="100" y="12" background="true" backgroundcolor="0x400000" backgroundalpha="0.667" border="true" bordercolor="0xFFFFFF" roundedge="11" shadow="0.1" shadowrange="12" shadowcolor="0xFFFFFF">

<layer name="left" url="vtourskin.png" scale="0.5" align="lefttop" x="10" y="6" crop="0|320|64|64" onclick="loadscene(scene_KitchenB));"/>

<layer name="left2" url="vtourskin.png" scale="0.5" align="lefttop" x="10" y="60" crop="0|320|64|64" onclick="loadscene(scene_KitchenC));"/>

<layer name="right" url="vtourskin.png" scale="0.5" align="lefttop" x="50" y="6" crop="0|320|64|64" onclick="loadscene(scene_KitchenD));"/>

<layer name="right2" url="vtourskin.png" scale="0.5" align="lefttop" x="50" y="60" crop="0|320|64|64" onclick="loadscene(KitchenE));"/>


</layer>

2

Samstag, 9. Februar 2019, 17:19

Ah Found it.
Just changed my buttons to

Quellcode

1
onclick="loadscene(scene_KitchenB,null, MERGE|KEEPVIEW, BLEND(0.5));

Problem solved. *smile*