You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

robertl

Beginner

  • "robertl" started this thread

Posts: 25

Location: Croatia

  • Send private message

1

Friday, February 15th 2019, 12:53pm

Config: VR and stereo support?

Hi!
Converting 12x1 stereo cube strips.

In my droplet config file I have:
stereosupport=true

and
customimage[vr].stereosupport=true

The problem is that VR images are not created unless I comment out one of those.
If I comment out customimage[vr].stereosupport=true, I get both multires in stereo and VR in stereo.
That seems weird.

Klaus, would you chime in?

2

Friday, February 15th 2019, 3:40pm

Hi,

I've just tested again and all stereo settings seems to work as they should...

Maybe try the MAKE VTOUR (VR-OPT) Droplet - it has:
stereosupport=false
and
customimage[vr].stereosupport=true

and this way it generates a mono-multires image for normal-viewing and stereo-images for VR-viewing.

Best regards,
Klaus

robertl

Beginner

  • "robertl" started this thread

Posts: 25

Location: Croatia

  • Send private message

3

Friday, February 15th 2019, 4:31pm

Hi,

I've just tested again and all stereo settings seems to work as they should...

Maybe try the MAKE VTOUR (VR-OPT) Droplet - it has:
stereosupport=false
and
customimage[vr].stereosupport=true

and this way it generates a mono-multires image for normal-viewing and stereo-images for VR-viewing.

I haven't given much thought to stereo multires. I guess I'd like to keep it for future compatibility. I can always generate a new XML.

So, currently I have enabled the stereosupport for stereo multires and commented out the customimage[vr].stereosupport. That combination produces both a stereo multires and stereo vr.
If I leave the customimage[vr].stereosupport=true, the vr images aren't generated.
Here is my full config:


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
# Virtual Tour with Multi-Resolution Panos
# Skin with Scrolling-Thumbnails, Bingmaps, Gyroscope, VR-Support
# Documentation: http://krpano.com/tools/kmakemultires/config?version=119
# krpano 1.19


# basic settings
include basicsettings-rl.config
panotype=autodetect
hfov=360
makescenes=true


# output
flash=true
html5=true


# convert spherical/cylindrical to cubical
converttocube=true
converttocubelimit=360x45


# multiresolution settings
multires=true
tilesize=512
levels=auto
levelstep=2
maxsize=auto
maxcubesize=auto
stereosupport=true


# output images path
tilepath=%INPUTPATH%/vtour/src/%BASENAME%.tiles/[c/]l%l/%v/l%l[_c]_%v_%h.jpg


# preview pano settings
preview=true
graypreview=false
previewsmooth=25
previewpath=%INPUTPATH%/vtour/src/%BASENAME%.tiles/preview.jpg


# generate thumbnails
makethumb=true
thumbsize=240
thumbpath=%INPUTPATH%/vtour/src/%BASENAME%.tiles/thumb.jpg

# generate smaller mobile images
customimage[mobile].size=768
customimage[mobile].path=%INPUTPATH%/vtour/src/%BASENAME%.tiles/thumbs/pano_%s.jpg
customimage[mobile].imagesettings=jpegquality=90 jpegsubsamp=444 jpegoptimize=true


# generate special optimized, non-tiled, lower-res images for VR
customimage[vr].size=1536
#customimage[vr].stereosupport=true
customimage[vr].path=%INPUTPATH%/vtour/src/%BASENAME%.tiles/vr/vr_%s.jpg
customimage[vr].imagesettings=jpegquality=95 jpegsubsamp=444 jpegoptimize=true
customimage[vr].xmlsceneparameters=havevrimage="true"
customimage[vr].xmlimageparameters=if="!webvr.isenabled"
customimage[vr].xmllevel=krpano
customimage[vr].xml=<image if="webvr.isenabled">[NL][TAB]<cube url="[PATH]" />[NL]</image>




# xml output
xml=true
xmlpath=%INPUTPATH%/vtour/tour.xml


# html output/template
html=true
htmlpath=%INPUTPATH%/vtour/index.html
htmltemplate_html5=auto


# skin / xml template
include vtourskin119-rl.skin


# include testing servers
htmltemplate_additional_file=html/tour_testingserver.exe
htmltemplate_additional_file=html/tour_testingserver_macos+x

4

Friday, February 15th 2019, 4:36pm

Hi,

If I leave the customimage[vr].stereosupport=true, the vr images aren't generated.

Okay - there is one special case about the 'custom images' - when the normal image is SMALLER than the custom image size and is of the SAME TYPE, then they are not generated - because in this case they would need to get upsampled and would be only waste of space and resources.

Best regards,
Klaus

robertl

Beginner

  • "robertl" started this thread

Posts: 25

Location: Croatia

  • Send private message

5

Friday, February 15th 2019, 4:38pm

Hi,

If I leave the customimage[vr].stereosupport=true, the vr images aren't generated.

Okay - there is one special case about the 'custom images' - when the normal image is SMALLER than the custom image size and is of the SAME TYPE, then they are not generated - because in this case they would need to get upsampled and would be only waste of space and resources.



You can count on me to hit that special edge case! :)
My input images are 18432x1536.