You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, April 8th 2019, 7:29pm

VR and Gyroscope not working on chrome for Android

Hi,

I created a simple pano tour using KR Pano 1.19 http://vr.waterlemonstudios.com/bougainvilla/ Gyroscope and VR is jittery on chrome for android [version 73.0.3683.90], but its working properly when I click on this example https://krpano.com/krpanocloud/webvr/?v=119pr15

Am I doing something wrong? Any help will be appreciated.

PS: It is working fine with Firefox browser for android.

Thanks!

spacerywirtualne

Professional

Posts: 866

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

2

Monday, April 8th 2019, 10:09pm

Hi

You have an old version of the Gyro2 Plugin (krpano 1.19-pr13)


http://vr.waterlemonstudios.com/bougainv…lugins/gyro2.js


Update your gyro2.js, webvr.js to latest version (1.19-pr16)


regards
Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

3

Tuesday, April 9th 2019, 5:53am

Hi Piotr,

Thank you for your help. Sorry for being a noob. Should I just redo the tour with the latest krpano?

Regards,
Prashanth

spacerywirtualne

Professional

Posts: 866

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

4

Tuesday, April 9th 2019, 9:48am

Swap the files in the 'plugins' directory with those from the latest version of krpano. That'll fix your problem.

You can of course update Krpano to the latest version, it is recommended.


Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

5

Tuesday, April 9th 2019, 11:26am

Its working now, thank you so much. It was a great help!

Sorry to bother, but am facing one more problem now. A fatal error occurs when loading tour.xml file in the vtour editor. The file is not loading.

Thanks in advance.