You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, April 29th 2019, 2:47pm

VR und Gyro werden in Chrome Version 74 nicht angezeigt

Hallo,

Ich habe folgendes Problem. In Chrome Version 74 wird bei mir die VR-Brille und das Gyroskop in all meinen virtuellen Touren nicht mehr angezeigt. In Chrome Version 73 funktioniert noch alles. Hat jemand eine Lösung dafür?

Viele Grüße
Venja Wilkens

2

Monday, April 29th 2019, 10:13pm

Hi,

dies hier dürfte das Problem sein (ein Auszug aus den Chrome 74 Release Notes):
https://chromium.googlesource.com/chromi…955f2a0450a85f4

D.h. der Gyroscope-Support wurde (wie auch bei iOS 12.2) auf 'sichere' HTTPS Seiten beschränkt.

Schöne Grüße,
Klaus

3

Tuesday, April 30th 2019, 9:16pm

I'm having a similar issue which is very problematic for my use-case... I create virtual tours of tiny homes for builders/designers to embed directly on their websites. I just noticed that the embed is not showing the VR option on mobile browsers (which is a feature that I promise to clients). Both my site and the client's site are secure HTTPS, but I guess this update to chromium does not treat the embed as secure?

Here is the actual tour location -> https://www.tinynestproject.com/explore/…omes/hugge_skp/
Here is the page on which it is embedded -> https://www.bengarratt.com/workshops

On my desktop I see the VR toggle in both cases, but on mobile it is missing from the embed (and obviously this VR is intended to be viewed on smartphones).

Any idea for a workaround? Is there a property that can be assigned to the embed somehow? Or a different method of embedding? This is my embed code:

Source code

1
<div style="text-align:center;width:80%;min-width:240px;max-width:640px;margin:0 auto"><iframe src="https://www.tinynestproject.com/explore/tiny-healthy-homes/hugge_skp/" width="100%" height="320" allowfullscreen></iframe><figcaption style="line-height:150%"><a href="https://youtu.be/mUjA1b8HmBM" target="_blank"><img src="https://www.tinynestproject.com/explore/EMBED-ASSETS/vr-embed_how-to_250x60_rev3.png" alt="How To Use This Tour" width="120"></a><a href="https://www.tinynestproject.com/embedded-tour/" target="_blank"><img src="https://www.tinynestproject.com/explore/EMBED-ASSETS/vr-embed_powered-by_250x60_rev2.png" alt="Powered by Tiny Nest" width="120"></a></figcaption></div>


EDIT: I just checked that the VR+gyro are available on mobile in embeds that are on my own site (within the same domain as the location of the actual tour) such as here -> https://www.tinynestproject.com/explore/services/
So the issue has to do with how the iframe is loading off-site content... is there any way to "validate" the contents of an iframe?

This post has been edited 2 times, last edit by "tinynestproject" (Apr 30th 2019, 9:38pm)


4

Thursday, May 2nd 2019, 2:13am

I found a solution by posting to a chromium google group and receiving a reply.
The thread is here: https://groups.google.com/a/chromium.org…dev/5yqfAXibz1I
The short answer was that I now have to explicitly allow some things within my iframes.

Source code

1
allow="gyroscope; vr"