You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, May 5th 2019, 10:19am

can tile index start with 0 instead of 1?

Hi there!

I'm currently evaluating KRPano as a replacement for SaladoViewer which is only flash based and sadly support for flash has been dropped from most browsers years ago.

SaladoViewer uses the Microsoft DeepZoom format. Panoramas can be defined with xml files like this:

Source code

1
2
3
4
<?xml version="1.0" encoding="utf-8"?>
<Image TileSize="953" Overlap="0" Format="jpg" ServerFormat="Default" xmnls="http://schemas.microsoft.com/deepzoom/2009">
<Size Width="30496" Height="30496" />
</Image>


I tried to translate that to your xml format which looks like this:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
<krpano>
<image type="CUBE" multires="true" tilesize="953">
  <level tiledimagewidth="30496" tiledimageheight="30496">
	<cube url="x_%s/15/%v_%h.jpg" />
  </level>
  <level tiledimagewidth="15248" tiledimageheight="15248">
	<cube url="x_%s/14/%v_%h.jpg" />
  </level>
  <level tiledimagewidth="7624" tiledimageheight="7624">
	<cube url="x_%s/13/%v_%h.jpg" />
  </level>
  <level tiledimagewidth="3812" tiledimageheight="3812">
	<cube url="x_%s/12/%v_%h.jpg" />
  </level>
  <level tiledimagewidth="1906" tiledimageheight="1906">
	<cube url="x_%s/11/%v_%h.jpg" />
  </level>
  <level tiledimagewidth="953" tiledimageheight="953">
	<cube url="x_%s/10/%v_%h.jpg" />
  </level>
</image>
</krpano>


Sadly the problem I encounter is that krpano starts indexing with 1 while the Microsoft DeepZoom format starts indexing with 0. Can I somehow tell the krpano viewer to start with 0 also, so that I don't have to reorder all existing panoramas to switch to your viewer?

With the xml config shown above I get an error console showing errors like this:

Source code

1
ERROR: loading of 'path/x_f/10/1_1.jpg' failed!
Ps.: I have not bought a license yet, I am still evaluating whether I want to make the switch.

2

Sunday, May 5th 2019, 1:27pm

Ah I found the parameter in the documentation behind the "show / hide advanced parameter" button that I missed before. Sorry for the trouble.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
<krpano>
<image type="CUBE" multires="true" tilesize="953" baseindex="0">
  <level tiledimagewidth="30496" tiledimageheight="30496">
	<cube url="x_%s/15/%h_%v.jpg" />
  </level>
  <level tiledimagewidth="15248" tiledimageheight="15248">
	<cube url="x_%s/14/%h_%v.jpg" />
  </level>
  <level tiledimagewidth="7624" tiledimageheight="7624">
	<cube url="x_%s/13/%h_%v.jpg" />
  </level>
  <level tiledimagewidth="3812" tiledimageheight="3812">
	<cube url="x_%s/12/%h_%v.jpg" />
  </level>
  <level tiledimagewidth="1906" tiledimageheight="1906">
	<cube url="x_%s/11/%h_%v.jpg" />
  </level>
  <level tiledimagewidth="953" tiledimageheight="953">
	<cube url="x_%s/10/%h_%v.jpg" />
  </level>
</image>
</krpano>