You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Edge@51

Beginner

  • "Edge@51" started this thread

Posts: 13

Location: Paris (France)

  • Send private message

1

Saturday, July 6th 2019, 2:16pm

Sound interface not working on Mac? [solved]

krpano has a strange behaviour lately: ht sound interface work correctly on Windows and iOs device, but on MacOs 10.14.5, I have no sound (on safari, chrome, firefox).

On exemple:
http://www.panochrome.fr/panoramas/monde…e_mombassa.html


My html code:

Source code

1
2
3
4
<!DOCTYPE html><html><head>	<title>Kénya - Cooperative Akamba</title>	<meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0" />	<meta name="apple-mobile-web-app-capable" content="yes" />	<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />	<style>		@media only screen and (min-device-width: 800px) { html { overflow:hidden; } }		html { height:100%; }		body { height:100%; overflow: hidden; margin:0; padding:0; font-family:Arial, Helvetica, sans-serif; font-size:16px; color:#FFFFFF; background-color:#000000; }		a{ color:#AAAAAA; text-decoration:underline; }		a:hover{ color:#FFFFFF; text-decoration:underline; }	</style></head><body>
<script src="../../../krpano/swfkrpano.js"></script>
<div id="pano" style="width:100%; height:100%;">	<noscript><table style="width:100%;height:100%;"><tr style="valign:middle;"><td><div style="text-align:center;">ERROR:<br/><br/>Javascript not activated<br/><br/></div></td></tr></table></noscript>	<script>		embedpano({swf:"../../../krpano/krpano.swf", xml:"cooperative_mombassa.xml", target:"pano"});	</script></div>
</body></html>



And the first part of my xml:

Source code

1
2
3
4
5
6
7
8
<krpano version="1.19">		<include url="../../../krpano/skin/defaultskin.xml" />
	<view hlookat="-70" vlookat="0" maxpixelzoom="1.0" fovmin="10.0" fovmax="110.0"/>	<display details="22" />
	<progress showload="no" showwait="no"/>		<autorotate enabled="true"			speed="5.0"		    waittime="1.0" />
	<preview url="cooperative_mombassa.tiles/preview.jpg" />


<plugin name="soundinterface"        url.flash="../../../krpano/soundinterface.swf"        alturl="../../../krpano/soundinterface.js"        preload="true"        rootpath=""        keep="true"        volume="0.4"        mute="false"        />        
	<events name="currentpano"	        onnewpano="playsound(bgsnd, 'cooperative_akamba.mp3', 0);" 	        onremovepano="stopsound(bgsnd);"	        />	



Does someone had any idea? It worked well for some times *confused*

This post has been edited 1 times, last edit by "Edge@51" (Aug 4th 2019, 2:08pm)


Edge@51

Beginner

  • "Edge@51" started this thread

Posts: 13

Location: Paris (France)

  • Send private message

2

Sunday, August 4th 2019, 1:43pm

Ok, I found the solution for safari: by default, the automatic sound player is disabled.
You have to go to the safari preferences => Websites => Autoplay and then allow your website.

The same on firefox: Preference => Privacy => Allow sound autoplay (or sorting like that, my system is in French: "Empêcher la lecture automatique de contenus sonores")
Edge@51 has attached the following images:
  • Capture d’écran 2019-08-04 à 14.04.28.png
  • Capture d’écran 2019-08-04 à 14.06.44.png

This post has been edited 2 times, last edit by "Edge@51" (Aug 4th 2019, 2:07pm)


3

Sunday, August 4th 2019, 7:37pm

this is not really a solution, because it only works on your browser
most browsers need a click to play audio nowadays...
i guess the coming new version also has improvements here