You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, October 2nd 2019, 1:13pm

Vers. 1.20 KR-Pano Tools starten nicht

Hallo @all,
habe mir die Version 1.20 auf mein WIN10 System geladen.

Problem: Das KR-Pano Tool startet nicht, auch nicht, wenn man die xml-Datei drauf zieht!!! ??? *cursing*

Was kann sein?
VG Frank

2

Wednesday, October 2nd 2019, 1:28pm

Hi,

das krpano Tools Programm basiert auf NWJS mit Chromium 65, d.h. eine Art Chrome Browser, fordert aber unbedingt Grafik-Hardware-Support.

D.h. wenn es nicht startet kann es eigentlich nur ein Problem mit dem Grafikkartentreiber geben.

Was für eine Grafikkarte bzw. GPU wird verwendet?
Und funktioniert WebGL im normalen Chrome Browser?

Schöne Grüße,
Klaus

3

Wednesday, October 2nd 2019, 3:48pm

Hallo Klaus ... und vielen Dank für die schnelle Antwort!
Eine NVIDIA GeForxe 570M (Laptop) macht die Grafikarbeit. Diese arbeitet ohne Probleme.

Wie kann man WebGL testen oder erkennen, ob dieser Dienst funktioniert?
Ich verwende allgemein Firefox aber Chrome hab ich auch installiert.


VG Frank
Ich hab ein Update der GPU durchgeführt, leider ohne Erfolg!???
lt. Taskmanager läuft "nwjs"....

This post has been edited 2 times, last edit by "FE-Foto" (Oct 2nd 2019, 4:59pm)


4

Thursday, October 3rd 2019, 10:18am

Wie kann man WebGL testen oder erkennen, ob dieser Dienst funktioniert?
Was steht denn im Chrome bei chrome://gpu/ ?

Bzw. funktionieren die Panoramen im Chrome?
Falls ja, wie ist die Performance?
Wenn Chrome die GPU nicht nutzen kann, verwendet es unter Umständen sehr langsames Software Rendering.

Ich vermute einmal Treiber Probleme zwischen NWJS (d.h. dem interem Chrome) und der GPU, viel kann man da aber leider nicht machen...

Schöne Grüße,
Klaus

5

Monday, November 18th 2019, 1:40pm

krpano tools

Bei mir scheint es das gleiche Problem zu sein. nwjs ist im Task-Manager geöffnet, es erscheint aber kein Programmfenster. Weder das direkte Öffnen noch das Öffnen einer xml klappt. Das Panorama öffnet über den Testing Server in Chrome und läuft gut.


chrome://gpu/ zeigt folgendes an:
Graphics Feature Status
  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Disabled
  • Hardware Protected Video Decode: Hardware accelerated
  • Rasterization: Hardware accelerated
  • Skia Renderer: Disabled
  • Video Decode: Hardware accelerated
  • Viz Display Compositor: Enabled
  • Viz Hit-test Surface Layer: Enabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

This post has been edited 1 times, last edit by "ajakob" (Nov 18th 2019, 2:31pm)


6

Sunday, November 24th 2019, 7:30pm

Hi,

das Problem liegt an dem NWJS Framework welches das krpano Tools Programm als Oberfläche verwendet.

Seit der Version 1.20 wird hier eine 64bit Version verwendet, welche aber leider offenbar mit ein paar älteren Grafikkarten ein Problem hat.

Eine mögliche Abhilfe wäre es hier die 32bit Version von krpano zu verwenden. Diese Version verwendet eine ältere NWJS Version (dieselbe wie in den vorherigen krpano Versionen).

Bei Bedarf wäre es auch möglich die 32bit und 64bit Version zu 'mischen' - d.h. die 'krpano Tools.exe' aus dem 32bit Download und die 'krpanotools.exe' aus dem 64bit Download. Die 64bit Version hat den Vorteil einer schnelleren Verarbeitung von sehr großen Bildern.

Schöne Grüße,
Klaus

Similar threads