You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Red

Trainee

  • "Red" started this thread

Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message

1

Wednesday, October 9th 2019, 8:40am

-SOLVED - Distorted video hotspots not showing on mobile or Oculus Go

Hi,
Thanks for the great update. I have an issue with distorted video hotspots not showing in mobile or Oculus Go. Desktop and VR on desktop is okay.
I've rebuilt the tour with 1.20.1 and copy/pasted hotpsot code for the previous tour. devices is set to "all". Any idea why this might be? Thanks

Source code

1
<hotspot name="video_foyera" devices="all" depth="off" videourl="%SWFPATH%/videos/foyer_screen.mp4" url="%SWFPATH%/plugins/videoplayer.swf" alturl="%SWFPATH%/plugins/videoplayer.js" posterurl="%SWFPATH%/images/shoponline.jpg" preload="true" distorted="true" enabled="false" width="480" height="270" ath="-81.41" atv="-22.66" edge="center" scale="0.295" rx="-6.97" ry="-12.48" rz="4.55" loop="true" pausedonstart="false" directionalsound="true" range="200" volume="0.7" onclick="togglepause();" />

This post has been edited 1 times, last edit by "Red" (Oct 9th 2019, 1:45pm)


2

Wednesday, October 9th 2019, 10:00am

try to remove devices="all" or set it to devices="" ...

there is no devices="all"
so this is most likely a condition never met, and your hotspots are not loaded

https://krpano.com/docu/xml/#devices

This post has been edited 1 times, last edit by "indexofrefraction" (Oct 9th 2019, 10:18am)


Red

Trainee

  • "Red" started this thread

Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message

3

Wednesday, October 9th 2019, 1:31pm

Thanks for the suggestion. I tried devices="normal|mobile|mobilevr" but still no joy.

Edit: Apologies - the posterurl image was missing. All good now.

4

Wednesday, October 9th 2019, 1:55pm

Source code

1
devices="normal|mobile|mobilevr" 


you dont have to define "all" *squint*
if devices is unset, it means "all"

device definitions are here, btw
https://krpano.com/docu/actions/#device.linux

maybe your problem is somewhere else

This post has been edited 2 times, last edit by "indexofrefraction" (Oct 9th 2019, 11:34pm)