You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

igor.socha

Intermediate

  • "igor.socha" started this thread

Posts: 196

Location: Tirol, Austria

Occupation: Photographer

  • Send private message

1

Friday, January 31st 2020, 2:35pm

how to run an action after loading new xml via loadscene?

I have two projects with the same panoramas: one created by krpano dropplet and one made in everpano. Is it possible to load everpano xml from krpano via loadscene(scenename, vars*, flags*, blend*), BUT WITH THE ACTION at the end?
(I need to run the action , which will bring me to the desired 3D position similar as in ABU SIMBEL example). I have this action, and it works in everpano project, but i need to run it from krpano xml. HOw to achieve this?
Thanks!
Best regards,
Igor Socha

igor.socha

Intermediate

  • "igor.socha" started this thread

Posts: 196

Location: Tirol, Austria

Occupation: Photographer

  • Send private message

2

Friday, January 31st 2020, 4:14pm

OKAY, seems that i made it to work.

while this action must be in first, tour.xml (created by krpano dropplet ):
<action name="test" > loadpano(main.xml,,PRELOAD|MERGE|KEEPVIEW|NOPREVIEW); transition_3_2_obraz1();</action>


it is calling the action which has to be physically in second, main.xml (created by everpano):

<action name="transition_3_2_obraz1"> loadscene(scene3,,PRELOAD); tween(view.tx|view.ty|view.tz, 20|0|400, 2.0, ,); lookto(93,-10,50,smooth(100,50,20));</action>

now it works, as I want
Best regards,
Igor Socha

This post has been edited 1 times, last edit by "igor.socha" (Jan 31st 2020, 5:00pm)


igor.socha

Intermediate

  • "igor.socha" started this thread

Posts: 196

Location: Tirol, Austria

Occupation: Photographer

  • Send private message

3

Friday, January 31st 2020, 4:57pm

Hmm, still one problem here :)

Tweening doesn´t end at the desired position of 20|0|400 but at the pre-defined ox oy and oz settings in everpano-rendered xml



<style name="everpano3d_2" panoname="hunady01" prealign="0|4.661|0" ox="30.825" oy="0" oz="541.750" linkedscene="scene2" />




How can i force it to end at 20 0 400? What´s wrong with my code?
Best regards,
Igor Socha

igor.socha

Intermediate

  • "igor.socha" started this thread

Posts: 196

Location: Tirol, Austria

Occupation: Photographer

  • Send private message

4

Saturday, February 1st 2020, 4:41pm

so to find out, i completely simplified Abu Simbel offline example project just to 2 panoramas and one info hotspot to learn the code and how it works :) After copying all the necessary code from Abu SImble project to my own it still didn´t work as expected and while moving from one pano to the desired one, it finished at the middle of new panorama instead at the desired tx/ty/tz. After a lot of time of trying i found the whole problem was caused by everpano navigator plugin and its settings (which i set in the beginning in everpano before rendering). after removing whole plugin code it works now as in Abu SImbel project and as i want - i have to do more tests though :)
Best regards,
Igor Socha