You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "sachagriffin" started this thread

Posts: 1,852

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

1

Sunday, February 16th 2020, 4:52am

Disable ALL Loadscene Blends for webvr..

Or maybe fix the issue.. ;)

Problem.. During the blend the view doesn't keep the viewpoint and its EXTREMELY nauseating. IE the whole scene rotates

Environment:
Using an oculus quest

Source code

1
loadscene(get(scene[get(goto)].name),null,MERGE,ZOOMBLEND(1,10));


I guess I can txtreplace everything under webvr... but... it's a workaround.

UPDATE
I can add keepmoving as a flag, there's just tiny stutter/jump now. Not sure where that's coming from. Happens in the krpano examples too.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

This post has been edited 1 times, last edit by "sachagriffin" (Feb 16th 2020, 5:14pm)


2

Thursday, February 27th 2020, 9:50am

I can add keepmoving as a flag, there's just tiny stutter/jump now.

Hi,

it depends on the actual example what could cause the short stutter, but typically it's the image-decoding by the browser. When using smaller images, like when using multi-resolution with the small tiles, then there should no or at least an fewer shorter interrupt. But anyway there will be improvements here with the next krpano releases by using newer browser-apis for doing the image-decoding in a worker/background-thread.

Best regards,
Klaus