You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, February 19th 2020, 11:33am

KEEPVIEW does not work on mobile in video 360

Hello! I have a tour of several 360 videos. When I enable the KEEPVIEW setting on the desktop, everything works fine, but on mobile it always shows the starting hlookat. Here is an example scene:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
<scene name="scene_ulisa" title="ulisa" onstart="" 
thumburl="panos/ulisa.tiles/thumb.jpg" isvideopano = "true" >		
<view hlookat="0.0" vlookat="0.0" fovtype="MFOV" fov="120" 
maxpixelzoom="1.0" fovmin="70" fovmax="140" distortion="0.0" />		
<include url="skin/videointerface.xml"/>
<image prealign = "0|-45|0">	 
<sphere url="plugin:video"   />	 
</image>				
<plugin name="video"			    k
keep="false"	 
url.html5="plugins/videoplayer.js"	 
url.flash="plugins/videoplayer.swf"	 
pausedonstart="false"	 
loop="true"	 
volume="1"	 
onloaded="add_video_sources();"	 
videourl=""  />	 
<action name="add_video_sources" devices="desktop" keep="false">
      videointerface_addsource('1video', 'videos/ulisa.mp4', 'photo/ulisa.jpg');  
videointerface_play('1video');  </action>
<action name="add_video_sources" devices="handheld" >
      videointerface_addsource('1video', 'videos/ulisa-small.mp4', 'photo/ulisa.jpg');  
videointerface_play('1video');  
</action>	 
<hotspot name="spot5" url="target2.png" style="khot"   ath="-12" atv="-3" linkedscene="scene_reception-small"  />		

	</scene>
I think it's a file: videointerface.xml makes this error

This post has been edited 3 times, last edit by "panorama07" (Feb 19th 2020, 1:33pm)


2

Saturday, February 22nd 2020, 11:13am

plugin[gyro].resetSensor(X); will help


regards,