You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, March 3rd 2020, 8:11pm

[RESOLVED] Krpano embedded with Iframe on sub-domain (https) not working on Android device


I have made search for hours on this problem...
I'm using PTP 2.5.14 & KRPano 1.19-pr16
If my tour is in my domain principal, everything works like charm embedding the tour with an iframe.
What i'd like to do is hosting my tour in a sub-domain, someting like and embed it this an iframe.
I've made lots of tests, and every time VR mode button is inactive on Android device (Samsung internet, firefox and Chrome include).

But, it's amazing to see that everythings works fine in GearVR (same device, Galaxy S8). Everything is fine on desktop (mac&PC).
I have tested with Amazon S3 hosting too... same problem... :(
I've read that the problem comes with last version of Chrome, and CORS configuration.

Do you have an idea to pass thru this problem? Or it's only a sad reality?
Thanks in advance, have a good day, or night...

This post has been edited 1 times, last edit by "Volkodlak" (Mar 4th 2020, 11:57am)



Posts: 1,111

Location: Poland, Europe

Occupation: krpano developer : virtual tours : the cms4vr owner

  • Send private message


Tuesday, March 3rd 2020, 10:02pm


did you add this params to the IFRAME code?

Source code

<iframe ... allowvr="yes" allow="vr; xr; accelerometer; magnetometer; gyroscope; autoplay;" allowfullscreen mozallowfullscreen="true" webkitallowfullscreen="true" ...></iframe>

Your own professional, online cloud tool for creating virtual tours -

facebook page :: youtube ::

cms4vr team *thumbsup*


Tuesday, March 3rd 2020, 10:20pm


Thanks for the response.
I've tried, but it doesn't work, i used this iframe:

Source code

<iframe src="" 
frameborder="0" allowvr="yes" allow="vr; xr; accelerometer; 
magnetometer; gyroscope; autoplay;" allowfullscreen 

I'm embedding it into a wordpress site hosted at
Everything works fine if the tour is in the main domain.

Just thinking this will never work *cry*
In fact, i don't understand why it works in gear vr with oculus browser, and doesn't work with other Androïd browsers.

This post has been edited 2 times, last edit by "Volkodlak" (Mar 4th 2020, 2:51am)


Tuesday, March 3rd 2020, 11:17pm


What type of SSL certificate did you install? You would need a Wildcard SSL Certificate to cover the sub-domain. Can you reach the tour via https at the sub-domain?




Tuesday, March 3rd 2020, 11:45pm

I'm using a wildcard ssl certificat from let's encrypt.

Everything's allright when calling the tour directly from his https adress on the sub domain.
I've tried to use it from another web site, and the problem is the same . And, i yes, i've got same problem from amazon s3 bucket.
Maybe a problem with Let's encrypt certificat?
Thanks for your help.


Wednesday, March 4th 2020, 12:00pm

Finally it works with your embbed code (Firefox no, but Chrome and Samsung internet are fine )
Thanks for your help.
Have a nice day, or night...