You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, May 9th 2020, 6:25am

Sound troubles in chrome - panotour + newest krpano update

hey! i am having some problems regarding sounds in google chrome. for a group i use a soundfile but the sound button in the navi doesnt work. if i click, then the sound starts to loop. also if i jump into a pano in another group the sound keeps playing (it should stop and only work inside the group. the troubles i have in google chrome and oper. firefox and edge is working fine. i use latest panotour version + latest krpano update. - thats the project https://noe360.at/360/heiligenkreuz/360/ - thx for the help

update: i removed the krpano panotour update and now everything works fine... so it looks like something is going on with the sound code in krpano udate....

This post has been edited 1 times, last edit by "pano-erbauer" (May 9th 2020, 7:25am)


2

Sunday, May 24th 2020, 4:08pm

Hi,

do you have a small/minimal PTP example (.kpt file) that shows the problem?

I'm short before releasing the next krpano version and have already removed several outdated and unnecessary device checks and workarounds (like a autoplay workaround) from the PTP xml templates that might be related to sound problem, but I'm not able to build a non-working PTP example so that I could test if these changes would work.

Best regards,
Klaus

3

Tuesday, May 26th 2020, 10:13am

thx will check out the newest update from you.
in the mean time i got it to work with a file provided from panotour plugins guy - http://www.panotourplugin.com/solved-aud…-krpano-1-20-x/

thank you for everything klaus, since many many years you are doing incredible work for us 360 freaks ;), keep up the good work!

4

Tuesday, May 26th 2020, 12:18pm

Hi,

thanks!

I have checked that file now - it basically does the same as my template updates in the 1.20.7 release - it removes the sound-autoplay-workarounds from PTP.

The newer krpano versions are handling all kind of autoplay-restritcions and workarounds automatically and these old manual workarounds in PTP are not checking if an workaround is even necessary and are therefore conflicting.

Best regards,
Klaus