You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, May 27th 2020, 3:31am

Cannot achieve any blending in a loadscene call

I created a few buttons that link to certain scenes from within a scene, it is actually the same room in different phases:

Source code

1
2
<layer style="button_go"   name="date2" align="topright" x="80" y="240" keep="false" type="text" html="2019 16.10." onclick="loadscene(scene_V_1_03_AK_MvF_19-10-16,MERGE,BLEND(2.0, linear));" />
<layer style="button_go"   name="date3" align="topright" x="80" y="270" keep="false" type="text" html="Plan"        onclick="loadscene(scene_V_1_03_AK_MvF_plan);" />


Neither version achieves a "blend", it is just switching in a snap. I do have this in my "skin_settings":

Source code

1
2
3
loadscene_blend=     "LIGHTBLEND(1.0, 0xFFFFFF, 2.0, linear)"
loadscene_blend_next="LIGHTBLEND(1.0, 0xFFFFFF, 2.0, linear)"
loadscene_blend_prev="LIGHTBLEND(1.0, 0xFFFFFF, 2.0, linear)"

I also tried to change it in the vtourskin.xml - despite this supposedly being overwritten by the skin_settings in tour.xml - but it did not give my any blending either.


Any ideas?
Thanks, Jenns

2

Wednesday, May 27th 2020, 12:37pm

Hi,

please check here the loadscene syntax:
https://krpano.com/docu/actions/#top

The blending setting is the fourth parameter.

Wrong:

Source code

1
loadscene(scene_V_1_03_AK_MvF_19-10-16,MERGE,BLEND(2.0, linear));

Correct:

Source code

1
loadscene(scene_V_1_03_AK_MvF_19-10-16,null,MERGE,BLEND(2.0, linear));


Btw - the'loadscene_blend' settings from the skin_settings are not krpano 'core' settings, they are only used by the actions defined in the vtourskin.xml.

Best regards,
Klaus

3

Wednesday, May 27th 2020, 4:16pm

Thanks a lot Klaus! The simple errors are always the most difficult to find, you look at it for hours and do not see it *rolleyes*