You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, August 10th 2021, 6:01pm

"Enter VR" strangely not works on Pico 4k VR headset

Hello Everyone!

I ran into a strange issue.

I have a Pico 4K VR headset. I tried to use it in VR mode with krpano. After several failures to properly enter into vr mode with my content i uploaded the examples folder from the krpano.

I'm using firefox reality browser on the Pico. When i click to the "ENTER VR" button on the krpano example it works perfectly. If i'm doing the same with the same example on my server it is not jumping into fullsceen mode. It stays windowed, but shows some strange splitsceen vr mode.

What can be the problem? What should i reconfigure on my server for proper vr mode? The first link is the working krpano link and the second is the same on my server.…tml5=only+webgl…tml5=only+webgl

Thank you for the help!


Sunday, August 15th 2021, 10:54am


Finally i found the solution. Somehow firefox reallity opens the secure with https, but my site is opened unsecure with http.


Sunday, August 15th 2021, 12:03pm

nowaday you cant even use the gyro without https *rolleyes*