You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, January 9th 2010, 1:40pm

Using kprotect for a single SWF multires image

Hello All,

I have having trouble understanding the kprotect tool and how to use it. I have spent some time coming the forum and doucmentation pages but documentation seems to be a bit hard to find.

So let me recap what I have done.

1.) I generated a a swf and associated files using MAKE PANO (SINGLE-SWF-MULTIRES) droplet.bat
2.) I renamed the base license file to match my .swf file (renamed to Baden.license)
3.) I posted the files to my test webserver (not local host) Files were called Baden.swf, Baden.html, Baden.license, Baden.jpg

I have purchased an unlimited domain license.

When opening the files from a mapped drive, I get the Krpano demo watermark, if I open the files using a webbrowser of http I get a LICENSE ERROR Message

How can I use Kprotect to embed the license in the swf? Will this solve my problem?

Phil

Trainee

Posts: 97

Location: Texas

  • Send private message

2

Saturday, January 9th 2010, 7:56pm

It sounds like you need to import your licenses into the kprotect tool or maybe try keeping the license name as krpano.license. This license setup only needs to be done once, not every time you use kprotect.

After opening the tool click on Setup.





Then click the Browse button to import you licenses. If you don't have the branding free license keep it blank and ignore the error message that it is missing. Click Install All and you're done.



Phil

3

Sunday, January 10th 2010, 4:00pm

Licenses look good in kprotect setup

Phil, Thanks for the note. I have checked the setup and it looks just like your screen shots. I had that setup already.

When I try to open the kprotect tool now however I get an error that my krpano.swf is invalid or too old.

I wonder if this has to do with a mismatch of versions of krpanotools and krpano viewer. I dowloaded the 1.0.7 zip for the viewer but I have 1.0.8 beta 9 on tools.

I'll do some more testing this afternoon and see what I can find out.

machart

Trainee

Posts: 135

Location: Ostfriesland

  • Send private message

4

Sunday, January 10th 2010, 4:06pm

you have to select the newest krpano.swf from the tools
__close to the rainbow__
_D300S|Sunwayfoto|iMaci7|PM|APP|KRP_
www.panographie.net

5

Sunday, January 10th 2010, 4:15pm

I think I've got the latest swf installed. in kprotect. here is what it looks like.



bopyd has attached the following image:
  • kprotectscreen.jpg

michel

Professional

Posts: 1,153

Location: ANDORRA

Occupation: TV

  • Send private message

6

Sunday, January 10th 2010, 6:11pm

Hi Bopyd,

Just click on Install to make this version the one used by kprotect...

SAlut.

7

Monday, January 11th 2010, 10:07am

Hi,

the solution is much more easier

regarding to:
1.) I generated a a swf and associated files using MAKE PANO (SINGLE-SWF-MULTIRES) droplet.bat
note - the SINGLE-SWF droplets are embedding the license into the generated swf file!
and therefore the both licenses must be in the folder of the tools/droplets,

when running the droplets without license, you will see a warning message in the command line window, and the generated swf will run in demo mode, which means it will show the demo watermark and it will work only locally,

best regards,
Klaus