You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, February 6th 2010, 11:20pm

ktransform & linux

Hello,

Because I had a bigger tif, I tried to use ktransform at my faster linux machine (I only have a slower windows computer to use some windows tools I can't use on linux). ktransform @ linux is sooooo much slooooooooowwwwerrr than on windows. Can you tell me why? Doing something wrong? I'm using the standard options, it's a 700mb 16bit tif I'm trying to convert to 6 cubes.

Maaike

This post has been edited 1 times, last edit by "maaike" (Feb 6th 2010, 11:59pm)


2

Sunday, February 7th 2010, 8:40am

You can run a "Sun VirtualBox" on your linux for running a windows from your linux session. It's working very fine for me.

David
Istanbul virtual tour creation : www.vizyon360.com

3

Tuesday, February 9th 2010, 12:42pm

Hi,

normally, it shouldn't be slower...

how much memory do you have installed on your linux machine?
and how much on windows?
and what version? (32/64bit? )

best regards,
Klaus

4

Tuesday, February 9th 2010, 12:52pm

Windows XP: 32bit, 2gb ram.
Linux: 64bit, 6gb ram.

But about the 32/64 bit: because you write this, I'm wondering if I used the 64bit version of the krpanotools, because I earlier used the 32 bit version (have a new pc since a few weeks). Is it possible that's the reason? I'll check this evening, when I'm home.

Thanks for the suggestion :).

5

Tuesday, February 9th 2010, 1:06pm

Hi,

it shouldn't be a problem, but yes, the 64bit linux version could be the problem...
please try also the 32bit version,

I must admit that I haven't tested a linux system with more than 4gb ram yet...

the tools are requesting the available memory from the system, and when here
a wrong (too low or negative) value will be returned, it will do much more swapping
to disk than necessary...

I will check this (and also add a kind of "verbose" option to allow displaying
more informations about the system/memory)

best regards,
Klaus

6

Tuesday, February 9th 2010, 1:12pm

one question more - what linux distribution are you using?

7

Tuesday, February 9th 2010, 1:48pm

I can help you test if you want to. I'll try the 32bit version and the 64 bit version this evening.

Distrubion: archlinux.

8

Tuesday, February 9th 2010, 8:21pm

Ok, I tried the 32bit and 64bit version together. The 64bit version on my linux machine is much much faster! More than 6x as fast I think (if you want to know exactly, I'll test that, but I don't have the patience for it right now).
Thanks for the hint!
Why do you need that huge amount of .swap-files?

9

Wednesday, February 10th 2010, 2:24pm

Hi,

I found the problem, it will be fixed in the next release,
(the return values of the linux system call sysinfo() had changed and it reported wrong values about available free memory)

here you could download quick pre-release for the meantime:
http://krpano.com/temp/uploads/

Why do you need that huge amount of .swap-files?
because of the wrong informations about the free memory
now there should be no .swap files until the image is very large,

best regards,
Klaus