You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

mindlessboss

Professional

Posts: 1,081

Location: Russia, Kaliningrad

  • Send private message

21

Wednesday, November 9th 2011, 3:18am

Hi!
NOHIDE in this example it's just an variable
set(NOHIDE,false); create new variable with name "NOHIDE" and set value to "false"
And you can use it after that.
You can create any variables you want, just set it's value.

Regards!

Andrey *thumbup*
VRAP - desktop VR content player based on krpano.
Common tasks in one place in one click! Discussion thread
DOWNLOAD for MAC
DOWNLOAD for WIN

22

Wednesday, November 9th 2011, 4:23am

Wow)) NOHIDE - is just variable? ) okay))
mindlessboss, Thanx!!

23

Wednesday, November 9th 2011, 1:11pm

Edit: somehow didn't see the above answer when I typed my answer. didn't mean to double answer.



He defined nohide as a variable and then checks it with an if code. Search for all the "nohide"s listed. Look at them collectively and it should make sense.


He sets it and has the if statement. Then in his onover and onout he changes the value of the variable allowing the if statement to work.



Hope that makes sense.

There are more articles regarding the variable. I questioned the rotateonclick?? in the nadir logo example just like you questioned this variable.

Jarred

sasky

Beginner

Posts: 17

Occupation: Trying to live as anybody else...

  • Send private message

24

Tuesday, January 17th 2012, 3:15pm

Sound does not play at all

Hey,

I was looking for it! Great idea and easy way to apply but I have issue.

When I keep the project offline I have log errors like so:

WARNING: not local trusted - ExternalInterface disabled!
ERROR: soundinterface - loading of "music.mp3" failed


and sound does not play, also when I put it online, errors does not occur and sound does not play neither.

I have upgraded krpano version to current so it's not a issue and I have tried a few mp3s as a sound and still does not work *huh*



Another question, If I want to set volume (on start) let say 50% of volume. What value should be placed on place %1 ??

<action name="setvolume">
set(soundinterface.volume,%1)
</action>


Best regards,
Martin

Tuur

Sage

Posts: 3,184

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

25

Tuesday, January 17th 2012, 4:02pm

Try to use the path relative from the plugin to the music.mp3 or from the index, or from the swf/.js

i'm not sure by head.. just try..

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

mstoss

Intermediate

Posts: 287

Location: Berlin

  • Send private message

26

Tuesday, July 17th 2012, 6:05pm

Thank you for posting!

This is really cool, thank you so much for posting!

All the best,
Michael