You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, March 15th 2010, 11:16am

krpano-neuling fragen

Hallo allerseits,
ich bin neu im umgang mit krpano und habe bisher hdview benutzt. Mittlerweile warten einige Panos auf meiner Platte, um endlich in Szene gesetzt zu werden.

ich hätte da mal ein paar typische neulings-fragen, nachdem ich gerade mit krpano anfange und mein erstes kleines pano von hdview auf krpano umgestellt habe:

- in hdview gibt es eine "home"-button, ist sowas in krpano auch möglich?
- ich bekomme die navigation nicht auf 2d-drag umgestellt. Obwohl es im xml angegeben ist, startet das pano im normalen navigations-modus.
- der drag-modus ist in hdview bei allen bewegungsänderungen gedämpft, in krpano nur beim stoppen, und auch nur, wenn man die maus rechtzeitig loslässt. Das macht die navigation imho zappelig und unruhig. Kann man das ändern?
- Beim herauszoomen wird in hdview das panorama schließlich ganz abgewickelt. In krpano wird die ansicht zu den rändern hin verzerrt, was wohl eigentlich korrekt ist, aber irgendwie ziemlich sinnfrei für den betrachter. Kann man auch das ändern?
- Was allerdings (leider) genauso wie bei hd-view ist, ist der umstand, dass ich es in typo3 nur als iframe eingebunden bekomme, was mich ziemlich nervt.
- Gibt es ein Tutorial, wie man ein Pano so einbindet, wie es hier auf der seite gemacht wurde? also quasi als banner, das sich zum pano aufzoomen lässt? Wobei ich es noch schöner fände, wenn die banner nicht durchgeklickt werden müssten, sondern als slideshow durchlaufen würden.
- Achja, und wenn ich z.b. das fov von 20-120° begrenzt habe, funktioniert diese begrenzung anfangs. Wenn ich aber übers kontext-menü auf z.b. little planet wechsel, und danach wieder auf normal gehe, ist die begrenzung raus.
- Eine eher fotografische Frage: Ich habe hier Panos von Menschenansammlungen auf nem Messestand gesehen. Wie fotografiert man denn sowas, wo die Leute sich doch dauernd bewegen?

was zumindest schon mal gut klappt, ist das einbinden der lizens-datei per krprotect *thumbup*

Im Laufe der nächsten Tage werden sicher noch weiter Fragen auftauchen... Die SuFu hat mir zwar schon in den Anfängen geholfen, aber leider weiß man ja oft anfags gar nicht, wonchach man überhaupt suchen soll...

Also entschuldigt bitte meine etwas einseitigen hdview-vergleiche und stümperhaften fragen *whistling*

This post has been edited 1 times, last edit by "Socke" (Mar 15th 2010, 11:44am)


2

Monday, March 15th 2010, 1:19pm

Hi,
- in hdview gibt es eine "home"-button, ist sowas in krpano auch möglich?
ich weiß jetzt nicht was der "home"-Button bei hdview genau macht, aber ich sag mal ja
z.B. bei der Verwendung des "MAKE PANO (FLAT) droplets" wird beim "Stern" Button komplett herausgezoomt
um das Gesamtbild zu sehen...

- ich bekomme die navigation nicht auf 2d-drag umgestellt. Obwohl es im xml angegeben ist, startet das pano im normalen navigations-modus.
eventuell wird diese noch dynamisch irgendwo umgestellt...
z.B. in meisten Default Templates für MAKE PANO Droplets wird mittels "onxmlcomplete" die Action "qtvrcursor"
aufgerufen, welche den QTVR Cursor samt "moveto" Steuerung setzt,


- der drag-modus ist in hdview bei allen bewegungsänderungen gedämpft, in krpano nur beim stoppen, und auch nur, wenn man die maus rechtzeitig loslässt. Das macht die navigation imho zappelig und unruhig. Kann man das ändern?
nein, beim Drag2D und Drag3D wird die neue Position sofort übernommen,


- Beim herauszoomen wird in hdview das panorama schließlich ganz abgewickelt. In krpano wird die ansicht zu den rändern hin verzerrt, was wohl eigentlich korrekt ist, aber irgendwie ziemlich sinnfrei für den betrachter. Kann man auch das ändern?
nein,


- Was allerdings (leider) genauso wie bei hd-view ist, ist der umstand, dass ich es in typo3 nur als iframe eingebunden bekomme, was mich ziemlich nervt.
mit typo3 kenne ich mich leider nicht aus...


- Gibt es ein Tutorial, wie man ein Pano so einbindet, wie es hier auf der seite gemacht wurde? also quasi als banner, das sich zum pano aufzoomen lässt? Wobei ich es noch schöner fände, wenn die banner nicht durchgeklickt werden müssten, sondern als slideshow durchlaufen würden.
das ist im Prinzip einfachstes Javascript - der 'Banner' wird in der Größe verändert, die restliche Seite ausgeblendet, und dynamisch ein IFrame mit dem Pano eingefügt, hier eine Link um Script - http://krpano.com/design/krpano.js



- Achja, und wenn ich z.b. das fov von 20-120° begrenzt habe, funktioniert diese begrenzung anfangs. Wenn ich aber übers kontext-menü auf z.b. little planet wechsel, und danach wieder auf normal gehe, ist die begrenzung raus.
die FOV Begrenzungen (eigentlich nur fovmax) werden in den Beispiels Actions umgesetzt,
da sonst z.B. kein Little Planet möglich wäre,


- Eine eher fotografische Frage: Ich habe hier Panos von Menschenansammlungen auf nem Messestand gesehen. Wie fotografiert man denn sowas, wo die Leute sich doch dauernd bewegen?
am besten mit einem Fisheye Objektiv, z.B. 8mm am Crop oder irgendwas mit 10-15mm am KB,

Schöne Grüße,
Klaus

3

Monday, March 15th 2010, 3:59pm

vielen Dank für die schnellen Antworten.

Das mit den gedämpften richtungswechseln im drag (2d) modus wäre von mir ein großer wunsch für vielleicht eine der nächsten versionen. Technisch sollte das ne kleinigkeit sein. ist ja schon drinn, nur eben nur im moveto-modus und beim drag-modus nur am ende.

das mit dem fisheye (ich hab son 8mm samyang am crop) mach ich auch jetzt schon, nur brauch ich auch damit 5 aufnahmen für ein kugelpano :(

an die anderen sachen mache ich mich mal ran, danke dir ;)

4

Wednesday, March 17th 2010, 10:07am

also... problemchen habe ich mit folgenden dingen:

- das pano mag nicht im drag2d-modus starten. ich hab folgendes eingestellt:

Source code

1
2
3
<control usercontrol ="all"
mousetype ="drag2d"
...

muss noch irgendwas eingestellt werden?

- ich habe ein recht großes nadir-logo eingebaut, da mein altes test-pano am boden ein großes loch hat. Wenn man jetzt aber mit der maus über das logo kommt, kann man nicht mehr navigieren. Es ist allerdings keine link für das logo angegeben. Kann man diese verlinkung abschalten? momentan sieht es so aus:

Source code

1
2
3
4
5
6
7
8
9
<hotspot name="nadirlogo"
url="wappen.gif"
ath="0"
atv="90"
distorted="true"
scale="1.0"
rotate="0.0"
rotatewithview="true"
/>


- wie kann ich einen "home-button" erstellen, also einen button, mit dem man auf die start-ansicht zurück schaltet?

5

Wednesday, March 17th 2010, 10:24am

nachtrag: ich denke, das mit dem logo kriege ich hin:
enabled und handcursor auf false sollte helfen, so verstehe ich zumindest die doku ;)

6

Wednesday, March 17th 2010, 10:44am

Hi,
- das pano mag nicht im drag2d-modus starten. ich hab folgendes eingestellt:

<control usercontrol ="all"
mousetype ="drag2d"
...

muss noch irgendwas eingestellt werden?
wie gesagt - eventuell wird "control.mousetype" noch irgendwo dynamisch in deinen XML Dateien geändert,
z.B. per - set(control.mousetype, moveto); - oder so...


ich habe ein recht großes nadir-logo eingebaut, da mein altes test-pano am boden ein großes loch hat. Wenn man jetzt aber mit der maus über das logo kommt, kann man nicht mehr navigieren. Es ist allerdings keine link für das logo angegeben. Kann man diese verlinkung abschalten? momentan sieht es so aus:
enabled="false" - reicht hier,
handcursor="false" kann dann verwendet werden wenn der Hotspot trotzdem aktiv/klickbar usw. sein soll,
aber keinen 'Hand'-Mausecursor anzeigen soll,
mittels capture="false" lässt sich dann noch weiter das "Fangen" der Maus ausschalten,
d.h. der Hotspot ist dann immer noch aktiv aber trotzdem kann das Pano mit Klicks darauf gesteuert werden,


- wie kann ich einen "home-button" erstellen, also einen button, mit dem man auf die start-ansicht zurück schaltet?
wenn das automatisch funktionieren soll,
wäre das eventuell eine Möglichkeit:

Source code

1
2
3
4
5
6
7
<events onxmlcomplete="speichere_start_ansicht();" />

<action name="speichere_start_ansicht">
  set(start_ansicht_hlookat, get(view.hlookat));  
  set(start_ansicht_vlookat, get(view.vlookat));
  set(start_ansicht_fov, get(view.fov));
</action>


hier werden die aktuellen Werte für die Blickrichtung und den Blickwinkel
direkt nach dem Laden der XML in eigene Variablen gespeichert,
(Achtung - falls das "onxmlcomplete" Event bereits verwendet wird, dann muss
der "speichere_start_ansicht();" - Auruf dort hinzugefügt werden!)

dann um zu dieser Ansicht per Button zurückzukehren:

Source code

1
2
3
4
5
<action name="zur_start_ansicht">
  lookto(get(start_ansicht_hlookat), get(start_ansicht_vlookat), get(start_ansicht_fov));
</action>

<plugin name="homebutton" ... onclick="zur_start_ansicht();" ... />


Schöne Grüße,
Klaus

7

Wednesday, March 17th 2010, 3:48pm

vielen dank für die schnelle hilfe *thumbsup*

8

Wednesday, March 17th 2010, 10:35pm

perfekt, funktioniert alles jetzt *w00t*

jetzt noch friction im drag-modus, und ich bin wunschlos glücklich *squint*

9

Friday, August 13th 2010, 9:39am

Ich wärme hier mal auf, da ich noch ein paar Problemchen habe:

ich bastel gerade an einer tour und habe das problem, dass das lookat und lookto beim wechsel der panoramen zwar prinzipiell funktioniert, beim überblenden aber eine falsche Position aus dem neuen Pano gezeigt wird, und dann nach dem fade erst die richtige (nicht geschwenkt auf die richtige, sondern quasi einfach umgeschaltet).

Es wird auch nicht überblendet, sondern das alte Pano wird ausgeblendet, und das neue danach eingeblendet.
Ich habs noch nicht hochgeladen, aber die xml-dateien der tour und beispielhaft 2 pano-xmls sind da, die ich in den nächsten Beitrag packe, das wird sonst mehr als 10000 Zeichen :(

Über sonstige Tipps zur Optimierung würde ich mich natürlich auch freuen.

Es sollen auch noch Textbeschreibungen und ein paar Hotspots rein, aber das werd ich wohl hinbekommen.

Was ich noch brauchen könnte, wäre eine Quelle für freie Hotspot-Flash-Dateien, da ich noch Pfeile und Symbole für Infotafeln brauchen könnte.

Aber wirklich wichtig ist erstmal, dass ich das Problem mit den Überblendungen hinbekomme...

edit: Hab die Dateien angehängt
Socke has attached the following files:
  • tour.xml (11.96 kB - 23 times downloaded - latest: Oct 3rd 2016, 1:13pm)
  • Kirche4.xml (3.89 kB - 14 times downloaded - latest: Sep 20th 2016, 7:18pm)
  • Kirche5.xml (3.66 kB - 9 times downloaded - latest: Sep 20th 2016, 7:19pm)

10

Friday, August 13th 2010, 9:46am

Hi,

in dem Fall gehört die Reihenfolge dieser zwei Befehle umgedreht:

Source code

1
2
wait(blend);
lookat(260,43,40);


also zuerst die Richtung setzen, und dann erst auf die Überblendung warten:

Source code

1
2
lookat(260,43,40);
wait(blend);


Schöne Grßüe,
Klaus

11

Friday, August 13th 2010, 11:13am

super, vielen dank, das funtioniert *thumbsup*

Jetzt hab ich noch eine Frage:
Wenn das erste Pano startet, bin ich wie gewünscht, im Drag 2D-Modus, aber sobald ich in die anderen wechsel, lande ich im moveto-modus, was ich aber nicht möchte. Wie kann ich das ändern? muss der drag 2d aufruf in jedes pano?

und wofür ist folgendes gedacht?

Source code

1
<contextmenu fullscreen="true"><item name="n0" enabled="true" visible="true" separator="true"      caption=""      onclick=""      /><item name="n1" enabled="true" visible="true" separator="true"      caption=""      onclick=""      /><item name="n2" enabled="true" visible="true" separator="false"      caption=""      onclick=""      /><item name="n3" enabled="true" visible="true" separator="false"      caption=""      onclick=""      /><item name="n4" enabled="true" visible="true" separator="false"      caption=""      onclick=""      /><item name="n5" enabled="true" visible="true" separator="false"      caption=""      onclick=""      /><item name="n6" enabled="true" visible="true" separator="false"      caption=""      onclick=""      /></contextmenu>



und auch das versteh ich nicht:

Source code

1
<action name="setuppano">action(dragcursor);if(ispartialpano == true,set(contextmenu.item[2].visible,false);set(contextmenu.item[3].visible,false);set(contextmenu.item[4].visible,false);set(contextmenu.item[5].visible,false);set(contextmenu.item[6].visible,false);,set(contextmenu.item[2].visible,true);set(contextmenu.item[3].visible,true);set(contextmenu.item[4].visible,true);set(contextmenu.item[5].visible,true);set(contextmenu.item[6].visible,true););</action>



und was muss noch am anfang der einer pano-xml stehen, wenn ja eigentlich alles aus der tour-xml übernommen wird?

achja, und wo ist der unterschied zwischen cube- und sphere-panos? kann man sphere-panos auch als multires nutzen?

*confused*

12

Saturday, August 14th 2010, 1:49pm

mein größtes problem ist momentan, ein logo so einzubinden, dass es bei jedem neuen pano angezeigt wird. Momentan wird es nur beim ersten angezeigt, danach nicht mehr. funktioniert auch nicht mit onpreviewcomplete statt onxmlcomplete, und ich hätte es gern, sobald die überblendung in das neue pano beginnt.

wenn ich von keepall auf merge gehe und fast alle actions kopiere und die plugins auf keep=true setze, geht es auch nicht. Zusätzlich wird dann aber auch die standard-button-leiste statt meiner eigenen benutzt.

edit:
Und gleich noch eine Frage: Wie kann ich den weiter oben erstellten "home-button" in einer tour so einsetzen, dass jedes pano seine eigene home-position hat? mit onpreviewcomplete scheint es zu funktionieren, muss ich aber noch testen.

Es wird eher mehr als weniger...
Ich habe mir buttons gebaut, um info-hotspots ein- und auszublenden. Klappt wunderbar, nur möchte ich, dass diese anfangs nicht sichtbar sind. Lege ich das "action(hidehotspots)" in onxmlcomplete, funktioniert es nicht. Lege ich es in onpreviewcomplete oder onloadcomplete, funktioniert es, aber die hotspots sind eben noch eine zeit lang sichtbar, das sieht etwas unprofessionell aus...
edit: funktioniert doch nicht zuverlässig *sad*

und nochwas: gibt es das standard-hotspot-flasch irgendwo als .fla? ich brauch noch andere farben als weiß und schwarz *blink*

So viele Fragen, aber es wird... Wenns fertig ist, wirds ein virtueller Rundgang durch unsere Kirche (wie tausende andere wohl auch) *smile*

This post has been edited 4 times, last edit by "Socke" (Aug 15th 2010, 8:01pm)


13

Monday, August 16th 2010, 3:59pm

vielleicht hilfts ja, mal reinzugucken?

http://www.behlendorf.de/fileadmin/pano/kirche/tour.html

edit: nach einem haufen copy and paste, und ersetzen von keepall durch merge, gehts schon viel besser. Das logo kommt immer noch nur am anfang, und die info-hotspots poppen immer noch kurz auf. homebutton funktioniert. info-hotspots funktionieren mit der genannten einschränkung.

Es scheint mir aber, als würde das jeweilige pano (bis auf das erste) immer gleich vollständig geladen werden, der ladebalken zittert auch so komisch rum. Weiß jemand, was das ist?

This post has been edited 1 times, last edit by "Socke" (Aug 16th 2010, 9:51pm)


14

Wednesday, August 18th 2010, 9:53am

Hi,

Quoted

Wenn das erste Pano startet, bin ich wie gewünscht, im Drag 2D-Modus, aber sobald ich in die anderen wechsel, lande ich im moveto-modus, was ich aber nicht möchte. Wie kann ich das ändern? muss der drag 2d aufruf in jedes pano?
soweit ich gesehen habe gibt es in jeder XML ein onxmlcomplete Event, wo die "qtvrcursor" Action aufgerufen wird, damit wird jedesmal wieder der QTVR Cursor samt moveto Steuerung gesetzt:

Source code

1
<events onxmlcomplete="action(setuppano); action(qtvrcursor);"

ich sehe du verwendet den vom Editor Plugin erzeugten XML Code, was hier (für Touren), leider nicht wirklich optimal ist...
die ganzen Default oder Leeren Einstellungen könnten entfernt werden, auch die doppelt vorhanden Knoten,
z.B. es genügt wenn die globalen Einstellung (z.B. der <event> Knoten) nur einmal in der tour.xml vorkommen,
das macht das Ganze auch übersichtlicher,

und nochwas: gibt es das standard-hotspot-flasch irgendwo als .fla? ich brauch noch andere farben als weiß und schwarz
sorry, dazu habe ich keine .fla, dieser Hotspot selber stammt nicht von mir, aber ich kann gerne den Kontakt weitergeben,


Es scheint mir aber, als würde das jeweilige pano (bis auf das erste) immer gleich vollständig geladen werden, der ladebalken zittert auch so komisch rum. Weiß jemand, was das ist?
das Zitteren des Ladebalken kommt davon, das die Dateigrößen erst zur Laufzeit ermittelt werden können und das sich durch das Zoomen der aktuelle Multiresolution Level ändert, womit wieder neue Datei zum Laden dazukommen,
ich arbeite noch daran dies zu verbessern, momentan würde ich einfach empfehlen den Ladebalken einfach komplett auszublenden (z.B. <progress showload="none" showwait="none" />) oder nur den 'Kreisel' anzuzeigen (<progress showload="none"/>),

Schöne Grüße,
Klaus

15

Wednesday, August 18th 2010, 11:53am

vielen Dank für die immer wieder kompetente Hilfe *thumbup*

Dass man das Logo bei jedem Einzel-Panorama neu einblendet geht nicht zufällig irgendwie?

Ich hatte schon versucht, viel von dem sich nicht ändernden "kram" in der tour.xml zu lassen, aber dann funktioniert es nicht, und jedes einzelne element durchprobieren wollte ich auch nicht. Eine Übersicht, welche elemente in jedes einzelpano rein müssen, auch wenn sie sich nicht ändern, gibt es nicht zufällig irgendwo?

ein kontakt zum macher der original hotspot-fla wäre sehr nett, vielen Dank! *thumbsup*

16

Wednesday, August 18th 2010, 12:00pm

Hi,
Eine Übersicht, welche elemente in jedes einzelpano rein müssen, auch wenn sie sich nicht ändern, gibt es nicht zufällig irgendwo?
wenn ein neues Pano mit dem MERGE Flag geladen wird,
dann bleiben alle Elemente wie sind sind, nur die <plugin>, <hotspot> und <lensflare> ohne - keep="true" - werden entfernt,

wird ein Element in der geladen XML neu definiert, überschreibt es damit das aktuelle (noch eine Anmerkung dazu - nur die gesetzten Attribute werden überschrieben),


ein kontakt zum macher der original hotspot-fla wäre sehr nett, vielen Dank!
bitte einfach eine kurze Mail diesbezüglich schrieben,

Schöne Grüße,
Klaus

17

Wednesday, August 18th 2010, 12:27pm

supi, das werde ich heute abend gleich ausprobieren *w00t*

18

Saturday, September 11th 2010, 8:37pm

So, nachdem ich mal wieder nicht weiter komme, muss ich leider wieder nerven *unsure*

1. Ich habe einige Textfelder eingebaut, habe aber Probleme mit der Höhe bei den höheren. Da ich das noch nicht hochgeladen habe, hier ein screenshot:


Dabei ist das Textfeld eigentlich in der richtigen Größe, was ich am Mauspfeil sehen kann, nur der Hintergrund und Rahmen nicht.
Der code dazu:

Source code

1
2
3
4
5
6
7
<!-- Textfeld 13 --><action name="show_html_field13">set(plugin[button].enabled,false);set(plugin[htmltext13].y,-1500);tween(plugin[button].alpha,0,,,set(plugin[button].visible,false));tween(plugin[htmltext13].alpha,1,0);tween(plugin[htmltext13].textblur,0,0);tween(plugin[htmltext13].blur,0,0);set(plugin[htmltext13].visible,true);set(plugin[htmltext13].enabled,true);tween(plugin[htmltext13].y,0);</action>


<plugin name="htmltext13" url="%SWFPATH%/plugins/textfield.swf"         align="center" width="400" height="700" x="0" y="-1100" visible="false"        html="data:html13"        css="data:css1"        roundedge="0"        borderwidth="1"        bordercolor="0x1F1F1F"        backgroundcolor="0xFFFFFF"        selectable="false"        shadow="5"        autosize="center"        />

<data name="html13"><p align="center"><font face="arial" size="+4"><b>Der Altar</b></font></p><a><img src="Altar-hinten-k.jpg" /></a><p align="left">Der eigentliche ALtar mit dem auf der Rückseite eingelassenen Opferstock stammt aus dem dreizehnten Jahrhundert.<br/><br/>Der  Altaraufsatz, eine frühbarocke Arbeit, wurde 1635 von der Witwe des ein Jahr zuvor verstorbenen Pächters des Hofes Behlendorf, Bernhard Brosius, Katharina, geb. Warendorp, gestiftet.<br/><br/> Auf dem Mittelbild kniet das Ehepaar Brosius mit ihren drei Kindern vor dem gekreuzigten Jesus. Zwei der Töchter, die linke und rechte werden zur Zeit der Stiftung schon verstorben sein, was ihre Bekleidung mit dem weißen Leichenhemd vermuten läßt.<br/><br/> Das untere Bild zeigt Jesu letztes Abendmahl.<br/></p>
<p align="center"><font size="+4"><a href="event:action(hidewindow,htmltext13);action(showbutton);">close window</a><br/></font></p></data>        




2. wie im pano zu sehen ( http://www.behlendorf.de/fileadmin/pano/kirche/tour.html ), blendet sich das hilfe-bild im intro ein, und auf draufklicken aus, das ist auch so gewollt, nur blendet es zu langsam aus, es sieht sogar so aus, als ob es zum ende hin langsamer wird. Ich tippe darauf, dass sich da 2 timer überschneiden, kann aber nix finden...


3. die map ist zu früh aktiv, man kann sie klicken, bevor anscheinend alles geladen wurde, und dann steht man im neuen pano ohne hotspots. Kann man das verzögern?


4. immer noch: kann man das Logo (Wappen) bei jedem neuen Pano einblenden lassen?


5. Das kriege ich zwar vermutlich selbst hin, aber man muss das rad ja nicht immer neu erfinden: wie kann ich einen knopf zum ein- und ausschalten der autorotation einbinden?


6. Je nach rechner ist die ganze animation recht ruckelig, gibt es da optimierungs-tips?

Da ich schon ne ganze weile an den Problemen festhänge, würde ich mich über jede Hilfe freuen, die mich weiter bringt *love*

19

Monday, September 20th 2010, 4:31pm

da ich noch kein stück weiter gekommen bin, muss ich das leider nochmal hochschubsen *cry*

20

Monday, September 27th 2010, 11:01am

Hi,

Quoted

1. Ich habe einige Textfelder eingebaut, habe aber Probleme mit der Höhe bei den höheren.
der HTML Renderer des Flashplayers ist leider sehr buggy, speziell mit Bildern,
ich würde empfehlen die Höhe manuell/fix vorzugeben, oder besser gleich
ein fertiges Bild anstelles des Textes zu verwenden,

2. wie im pano zu sehen ( http://www.behlendorf.de/fileadmin/pano/kirche/tour.html ), blendet sich das hilfe-bild im intro ein, und auf draufklicken aus, das ist auch so gewollt, nur blendet es zu langsam aus, es sieht sogar so aus, als ob es zum ende hin langsamer wird. Ich tippe darauf, dass sich da 2 timer überschneiden, kann aber nix finden...
du könntest versuchen eine kürze Zeit (momentan ja 1.5 Sekunden) und einen andere 'tween' Art zu wählen,
die Default tween Bewegungs ist die "easeOutQuad" und diese wird zum Ende hin langsamer,
siehe hier:
http://krpano.com/docu/actions/#tweentypes
bzw. hier:
http://hosted.zeh.com.br/tweener/docs/en…ransitions.html


3. die map ist zu früh aktiv, man kann sie klicken, bevor anscheinend alles geladen wurde, und dann steht man im neuen pano ohne hotspots. Kann man das verzögern?
besteht das Problem noch? das konnte ich jetzt nachvollziehen...


4. immer noch: kann man das Logo (Wappen) bei jedem neuen Pano einblenden lassen?
wie ist das gemeint?
das Logo soll sich bei jedem Pano neu einblenden und dann wieder ausblenden?

dazu könntest du z.B. noch eine "fadein" Action, mit der das Logo eingeblendet wird, hinzufügen und dann ebenfalls im "onxmlcomplete" Aufrufen, dann muss allerdings die "fadeout" Action irgendwie verzögert werden, z.B. mittels einen delayedcall,
z.B.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
<plugin name="logo"
	keep="true"
	url="wappen1.png"
	align="rightbottom"
	x="10"
	y="10"
	enabled="false"
    	alpha="0.0"
	/>

<action name="fadein">
  set(plugin[logo].alpha,0);
  set(plugin[logo].visible,true);
  tween(plugin[logo].alpha,1.0);
  delayedcall(4, fadeout() );
</action>

<action name="fadeout">
  tween(plugin[logo].alpha,0,7,easeInExpo,set(plugin[logo].visible,false));
</action>

<events onxmlcomplete="action(setuppano); action(qtvrcursor); action(hidehotspots); fadein(); action(speichere_start_ansicht);"
...


5. Das kriege ich zwar vermutlich selbst hin, aber man muss das rad ja nicht immer neu erfinden: wie kann ich einen knopf zum ein- und ausschalten der autorotation einbinden?

Source code

1
<plugin name="autorotatebutton" ... onclick="switch(autorotate.enabled);" ... />



6. Je nach rechner ist die ganze animation recht ruckelig, gibt es da optimierungs-tips?
eventuell ohne Multires probieren, d.h. einfache 6 Bilder,
autorotate nicht dauerhaft und sofort aktiv, damit der Rechner auch mal pausieren kann,
die display.fps wieder auf 60 setzen,
display.flash10 während des "little planet" intros ausschalten - set(display.flash10,off);

Schöne Grüße,
Klaus