You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, March 20th 2010, 4:39pm

simplevierwer pro mit verschiedenen gallerien nutzen

hallo,

nachdem ich die simpleviewerlösung im forum gefunden habe, versuche ich gerade das für verschiedene gallerien umzusetzen,

da dies ja mit der kostnix-version nicht geht.

ich hab für jedes pano ein fotoverzeichnis und dort die simpleviewer.swf, gallery.xml und die bilder drin.

wen ich in der jeweiligen pano-xml-datei die galerie aufrufen will, bekomme ich folgenden fehler:

ERROR: download of "fotos123/simpleviewr.swf?xmlDataPath=gallery.xml" failed

finde momentan keinen ansatzpunkt mehr *evil*

sascha



so binde ich die gallerie im xml ein:

<plugin name="gallery" url="" visible="false" alpha="0" />
<plugin name="showgallery" url="images/b_galerie.png" zorder="2"align="lefttop" x="60" y="30" visible="true" alpha="1" onclick="action(showgallery);" />
<plugin name="hidegallery" url="images/b_galerie.png" zorder="1" align="lefttop" x="60" y="30" visible="false" alpha="1" onclick="action(hidegallery);" />
<action name="showgallery">freezeview(true); tween(plugin[logo].alpha,0,distance(1,0.15),,set(plugin[logo].visible,false)); set(plugin[showgallery].enable,false); tween(plugin[showgallery].alpha,0,distance(1,0.15),,set(plugin[showgallery].visible,false)); set(plugin[hidegallery].enable,true); set(plugin[hidegallery].visible,true); tween(plugin[hidegallery].alpha,1,distance(1,0.15)); set(plugin[gallery].url,fotos123/simpleviewer.swf?xmlDataPath=gallery.xml); set(plugin[gallery].visible,true); tween(plugin[gallery].alpha,1,distance(1,0.15));</action>
<action name="hidegallery">tween(plugin[gallery].alpha,0,distance(1,0.15),,action(closegallery));</action>
<action name="closegallery">set(plugin[gallery].visible,false); freezeview(false); set(plugin[logo].visible,true); tween(plugin[logo].alpha,1,distance(1,0.15)); set(plugin[hidegallery].enable,false); tween(plugin[hidegallery].alpha,0,distance(1,0.15),,set(plugin[hidegallery].visible,false)); set(plugin[showgallery].enable,true); set(plugin[showgallery].visible,true); tween(plugin[showgallery].alpha,1,distance(1,0.15));</action>

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

2

Saturday, March 20th 2010, 5:49pm

Das hatte ich bei meiner Umsetzung der psGallery auch.
Da ist sicher der Pfad nur falsch gesetzt.

Ist der Pfad absolut ab der ersten SWF-Ddatei (krpano.swf)?
Setze alternativ mal den Pfad absolut ab root: /ordner/order2/datei.swf

3

Saturday, March 20th 2010, 6:21pm

damit ist die fehlermeldung weg, jetzt bekomme ich vom simpleviewer die meldung "GALLERY XML NOT FOUND"

*confused*

<plugin name="gallery" url="" visible="false" alpha="0" />
<plugin name="showgallery" url="/images/b_galerie.png" zorder="2"align="lefttop" x="60" y="30" visible="true" alpha="1" onclick="action(showgallery);" />
<plugin name="hidegallery" url="/images/b_galerie.png" zorder="1" align="lefttop" x="60" y="30" visible="false" alpha="1" onclick="action(hidegallery);" />
<action name="showgallery">freezeview(true); tween(plugin[logo].alpha,0,distance(1,0.15),,set(plugin[logo].visible,false)); set(plugin[showgallery].enable,false); tween(plugin[showgallery].alpha,0,distance(1,0.15),,set(plugin[showgallery].visible,false)); set(plugin[hidegallery].enable,true); set(plugin[hidegallery].visible,true); tween(plugin[hidegallery].alpha,1,distance(1,0.15)); set(plugin[gallery].url,/panos/fotos123/simpleviewer.swf?xmlDataPath=gallery.xml); set(plugin[gallery].visible,true); tween(plugin[gallery].alpha,1,distance(1,0.15));</action>
<action name="hidegallery">tween(plugin[gallery].alpha,0,distance(1,0.15),,action(closegallery));</action>
<action name="closegallery">set(plugin[gallery].visible,false); freezeview(false); set(plugin[logo].visible,true); tween(plugin[logo].alpha,1,distance(1,0.15)); set(plugin[hidegallery].enable,false); tween(plugin[hidegallery].alpha,0,distance(1,0.15),,set(plugin[hidegallery].visible,false)); set(plugin[showgallery].enable,true); set(plugin[showgallery].visible,true); tween(plugin[showgallery].alpha,1,distance(1,0.15));</action>

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

4

Saturday, March 20th 2010, 8:11pm

auch dort den pfad ab root setzen

5

Saturday, March 20th 2010, 9:43pm

ich hab jetzt überall den pfad angepasst, meldung immer noch die selbe GALLERY XML NOT FOUND *cry*

die pano xml liegt im verz. /360 und die gallery.xml wie auch die simpleview.swf in /360/fotos

meine pano xml:
<plugin name="gallery" url="" visible="false" alpha="0" />
<plugin name="showgallery" url="/360/images/b_galerie.png" zorder="2"align="lefttop" x="60" y="30" visible="true" alpha="1" onclick="action(showgallery);" />
<plugin name="hidegallery" url="/360/images/b_galerie.png" zorder="1" align="lefttop" x="60" y="30" visible="false" alpha="1" onclick="action(hidegallery);" />
<action name="showgallery">freezeview(true); tween(plugin[logo].alpha,0,distance(1,0.15),,set(plugin[logo].visible,false)); set(plugin[showgallery].enable,false); tween(plugin[showgallery].alpha,0,distance(1,0.15),,set(plugin[showgallery].visible,false)); set(plugin[hidegallery].enable,true); set(plugin[hidegallery].visible,true); tween(plugin[hidegallery].alpha,1,distance(1,0.15)); set(plugin[gallery].url,/360/fotos/simpleviewer.swf?xmlDataPath=/360/fotos/gallery.xml); set(plugin[gallery].visible,true); tween(plugin[gallery].alpha,1,distance(1,0.15));</action>
<action name="hidegallery">tween(plugin[gallery].alpha,0,distance(1,0.15),,action(closegallery));</action>
<action name="closegallery">set(plugin[gallery].visible,false); freezeview(false); set(plugin[logo].visible,true); tween(plugin[logo].alpha,1,distance(1,0.15)); set(plugin[hidegallery].enable,false); tween(plugin[hidegallery].alpha,0,distance(1,0.15),,set(plugin[hidegallery].visible,false)); set(plugin[showgallery].enable,true); set(plugin[showgallery].visible,true); tween(plugin[showgallery].alpha,1,distance(1,0.15));</action>



meine gallery xml:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewergallery title="SimpleViewer Gallery" textColor="FFFFFF" frameColor="FFFFFF" thumbPosition="LEFT"

galleryStyle="MODERN" thumbColumns="3" thumbRows="4" showOpenButton="TRUE" showFullscreenButton="TRUE"

frameWidth="20" maxImageWidth="800" maxImageHeight="800"

imagePath="/360/fotos/" thumbPath="/360/fotos/thumb/"
useFlickr="false"
flickrUserName=""
flickrTags=""

languageCode="AUTO"
languageList=""
enableAPI="TRUE"
>

<image imageURL="image1.jpg" thumbURL="image1.jpg" linkURL="" linkTarget="" ><caption></caption></image>

</simpleviewerGallery>

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

6

Saturday, March 20th 2010, 9:59pm

sieht eigentlich erstmal korrekt aus.
die frage ist jetzt, hast du es mit eineml relativen pfad zur sv.swf mal getestet?

7

Saturday, March 20th 2010, 10:37pm

ich weiß nicht, wie viele pfadkombis ich schon getestet habe *blink*

set(plugin[gallery].url,fotos/simpleviewer.swf?xmlDataPath=gallery.xml);

auf jeden fall muss der fehler wohl im finden dieser sch... url liegen *angry*

8

Saturday, March 20th 2010, 11:59pm

.url,simpleviewer.swf?xmlDataPath=gallery.xml);

wenn ich es so mache und die gallery.xml und die simpleviewer.swf im selben hauptverzeichnis habe, klappt es!

packe ich die gallery.xml und simpleviewer.swf und bilder etc. in das verzeichnis fotos kann ich wieder alle möglichkeiten ausprobieren, aber es klappt nicht.

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

9

Sunday, March 21st 2010, 9:20am

Das klingt ganz danach, als ob im sv die url der gallery fest verdrahtet ist.
es schein, als ob sv diese immer im gleichen verzeichnis wie die swf selbst erwartet und einem nur die möglichkeit der namensänderung (dateinamen) bereithält.

da aber beim einbinden der pfad immer ab der krpano gilt, wäre das sehr schlecht.

10

Sunday, March 21st 2010, 1:55pm

vielleicht weiß ja klaus rat :-)

hier mal ein link mit editor plugin: www.wir-sind-legden.de/123




so gehts mtt einer galerie:

simpleviewer.swf?xmlDataPath=gallery.xml

wobei hier die grossansicht nicht gezeigt wird und es oben links in die ecke geknetsch wird.

so kommt die meldung: gallery xml not found:
simpleviewer.swf?xmlDataPath=/123/fotos/gallery.xml
simpleviewer.swf?xmlDataPath=gallery123.xml (bei versch. gallerien)

11

Monday, March 22nd 2010, 1:48pm

alternative zu simpleviewer - aber noch 1 problem

ich habe evtl. eine flash-alternative zu simpleviewer.

die xml wird gefunden, die thumbs auch, nur die großansicht zeigt nicht an.

da kommt die meldung NaN% - hab von flash nicht wirklich ahnung. was könnte das denn sein?

so ist`s im pano eingebunden:

<plugin name="showgallery" url="b_galerie.png" align="lefttop" x="80" y="30" keep="true" scale="0.4" visible="true" zorder="100" alpha="1" onclick="action(showgallery);" onhover="showtext(Open gallery);" />

<plugin name="hidegallery" url="b_galerie.png" align="lefttop" x="80" y="30" keep="true" scale="0.4" visible="false" zorder="100" alpha="1" onclick="action(hidegallery);" onhover="showtext(Close Gallery);" />


<plugin name="gallery" url="" visible="false" width="800" height="600" keep="true" alpha="0" />


<action name="showgallery">freezeview(true); set(plugin[showgallery].enable,false); tween(plugin[showgallery].alpha,0,distance(1,0.15),,set(plugin[showgallery].visible,false)); set(plugin[hidegallery].enable,true); set(plugin[hidegallery].visible,true); tween(plugin[hidegallery].alpha,1,distance(1,0.15)); set(plugin[gallery].url,galerie.swf?xmlDataPath=galerie.xml); set(plugin[gallery].visible,true); tween(plugin[gallery].alpha,1,distance(1,0.15)); set(plugin[gallery].align,center); set(plugin[gallery].width,800); set(plugin[gallery].height,600);</action>
<action name="hidegallery">tween(plugin[gallery].alpha,0,distance(1,0.15),,action(closegallery));</action>
<action name="closegallery">set(plugin[gallery].visible,false); freezeview(false); set(plugin[hidegallery].enable,false); tween(plugin[hidegallery].alpha,0,distance(1,0.15),,set(plugin[hidegallery].visible,false)); set(plugin[showgallery].enable,true); set(plugin[showgallery].visible,true); tween(plugin[showgallery].alpha,1,distance(1,0.15));</action>




www.wir-sind-legden.de/456

in einer reiner html-seite läuft es ohne probleme:

www.wir-sind-legden.de/456/test.html

12

Wednesday, March 24th 2010, 8:13pm

jemand mit flashkenntnissen da?

gibt`s hier vielleicht jemanden, der in flash fitter ist?

ich denke die flashgalerie in krpano mit einzubinden wäre ne coole sache für alle.

vermutlich liegt es nur noch an ner kleinigkeit.

ich stelle die fla-datei gerne zur verfügung.

bei interesse ne kurze pm an mich.

sascha

13

Tuesday, March 30th 2010, 4:21pm

Hi,
so gehts mtt einer galerie:

simpleviewer.swf?xmlDataPath=gallery.xml

wobei hier die grossansicht nicht gezeigt wird und es oben links in die ecke geknetsch wird.
der Simplerviewer ist ein AS2 (Flash8) Programm, diese können in AS3 (Flash9/10) Programmen nur
geladen aber nicht wirklich gesteuert und auch richtig nicht entladen werden,

d.h. ein Neuladen mit anderen Parametern (anderer gallery XML) ist unter Umständen nicht möglich,

zu "oben links in die ecke geknetsch" - das liegt vermutlich an den "width" und "height" angeben,
bei der Einbindung hier:

Source code

1
<plugin name="gallery" url="" visible="false" width="800"  height="600" keep="true" alpha="0" /> 


der Simpleviewer positioniert sich vermutlich selbst, da stören diese Angaben dann,
so sollte es funktionieren:

Source code

1
<plugin name="gallery" url="" visible="false" keep="true" alpha="0" /> 


Schöne Grüße,
Klaus

Posts: 113

Location: Berlin

Occupation: Panoramafotograf

  • Send private message

14

Friday, September 10th 2010, 4:34pm

Mehrere Galerien, Lösung gefunden?

Hallo Alle,

das Problem mit den Simple Viewer Galerien ist ja schon mehrfach hier behandelt worden: es gibt, oder gab keine Lösung, um in jedem Pano eine andere Galerie anzuzeigen. Nun sind ja ein paar Monate ins Land gezogen, hat sich da etwas getan? Oder soll ich die Suche aufgeben und meine Zeit sinnvoller nutzen?

Gruß, Jan
(da arbeite ich gerade dran: http://www.panographer.de/wp-content/tou…/projektbar_02/)
Jan Totzek | Panoramafotografie | Berlin
www.panographer.de

15

Monday, September 13th 2010, 2:41am

hallo jan,

die simpleviewer pro version hab ich wieder zurück gegeben ;-(

habe auch noch verschiedene andere flashgalerien bis zum umfallen getestet - erfolglos.

ich begnüge mich momentan mit der "normalen" galerie, die krpano zur verfügung stellt.

vg

sascha

Posts: 113

Location: Berlin

Occupation: Panoramafotograf

  • Send private message

16

Monday, September 13th 2010, 3:58pm

na dann...
danke sascha. erspart mir noch mehr rumgeier!
Jan Totzek | Panoramafotografie | Berlin
www.panographer.de