You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, April 26th 2010, 10:44am

Sync-Fehler?

Hallo Klaus!

--> Edit per 26.04. 18.13: Fehler (voraussichtl) gefunden: Das ist ja ein partielles Pano; wahrscheinlich stimmte also meine Gradangabe (partieller Bereich) beim pano-Erstellen (für "MAKE PANO (MULTIRES) droplet.app") nur in etwa und nicht genau...

Bitte starte mal in die Tour
http://buckligewelt.panaustria.at
und wähle aus dem Dropdown-Menu "Auswahl Alle Panoramen" das 3. Pano von oben "Fernsicht Windradplattform".

Das ist ein partielles Pano, mit Tele aufgenommen; man sieht ca. 100km weit im Zirkel von Schneeberg-Wien-Seewinkel.
Links unten erscheinen Sprungziele. Wenn man auf "Wien" klickt zoomt das Pano den Stephansdom in der Bildmitte heran. bei geöffneter Karte (groß machen und rauszoomen) erkennt man, daß die Blickrichtung ganz(!) genau stimmt; Wiens Zentrum liegt genau in der Strahlmitte des googlemap-radarbeams.

Wenn man nun aber Bratilava anklickt und (am Horizont noch erkennbar) die Burg Preßburg präsentiert bekommt, wird die Richtung in der googlemap nicht korrekt angezeigt - sie weist über Hainburg und dann doch deutlich westlich an Pressburg (die Burg liegt am südl. Stadtrand) vorbei. Die Abweichung ist vielleicht nur 5 Grad, was aber in dieser zoomstufe schon einen Schwenk von 2-3 Bildschirmbreiten sind! (vice versa: wenn ich lt. googlemap die korrekte Richtung eistelle, zeigt das Pano einen Bereich weiter östlich...).

Hast Du eine Idee/Erklärung dafür?
best regards from www.PanAustria.com

This post has been edited 1 times, last edit by "PanAustria" (Apr 26th 2010, 6:17pm)


iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

2

Monday, April 26th 2010, 2:02pm

Ist zwar off-Topic, aber wie hast Du denn die auto-Kontrast-Boost-Fkt. umgesetzt?
Sind das überlagerte Hotspotbilder oder tauschst Du einfach die Panobilder?

3

Monday, April 26th 2010, 6:11pm

Nachdem das ja ein multilevel-Pano ist, habe ich einfach die betroffenen tiles der entspr. zoomstufe anders eingestellt (per Stapelverarbeitung von Photoshop).
Sollte aber seit dem letzten viewer-update auch "eleganter" gehen, da nun das zu rendernde image als actionscript-sprite ansprechbar und damit über filter veränderbar ist. Man sollte jetzt also mit ein wenig as3-coding das pano in seiner Helligkeit/ Kontrast, etc verändern können; hab´s aber noch nicht ausprobiert.

lG
best regards from www.PanAustria.com

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

4

Monday, April 26th 2010, 6:50pm

Danke für die Info.

Ich meinte aber eigentlich das Austauschen im krpano ;-)

5

Monday, April 26th 2010, 7:29pm

Was genau meinst Du – da wird nämlich nichts (dynamisch) "ausgetauscht"; ich hab lediglich am Server alle tiles der zoomstufe 4 in den relevanten Bildbereichen gegen Versionen mit nachgearbeiteter Tonwertanpassung "ausgetauscht" ...

Ist das unklar?
best regards from www.PanAustria.com

iceman_fx

Professional

Posts: 602

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

6

Monday, April 26th 2010, 8:53pm

Jetzt ist es klar.
Auf diese Weise kann man das natürlich auch machen - ich dachte erste Du machst dies per Code.

Similar threads