You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

raimondo

Beginner

  • "raimondo" started this thread

Posts: 22

Location: Bad Kreuznach

Occupation: Fotograf

  • Send private message

1

Tuesday, May 4th 2010, 4:20pm

offline ...grau... /online ...garnix

Da hab ich doch mit viel Vorfreude die teure Version googlemaps für krpano erworben und hab jetzt nix... kann das denn sein ? *confused*
Habe aus dem Plugin-Beispiel alles abgekupfert, meinen API hinzugefügt und erhalte an der gewünschten Stelle ein mausgraues Feld, nachdem ich die Vertrauenswürdigkeit meiner eigenen Seite offline meinem Browser bestätigen mußte. Alles mal so auf den Server gebracht und ... erstaunt, erstaunt ...garnix, das heißt mein Pano läuft aber wenigstens ohne graues Feld. Der Fehler liegt immer bei mir ! aber wo ?

2

Tuesday, May 4th 2010, 4:56pm

offline ...grau... /online ...garnix

hast du ein Beispiel?? ... vielleicht ist dein Zoom-Level zu hoch? Denn in vielen Regionen gibts da kein Bildmaterial bei google und dann bleibt alles grau... normalerweise sollte je nach Größe des Ausschnitts eine Meldung kommen wie "Karten mit diesem Zoomwert stehen für diese Region leider nicht zur Verfügung..." Auch wenn man zu schnell reinzoomt hat man den Effekt und Google lädt nicht schnell genug nach.

Stell mal einen Zoom="15" ein da sollte was zu sehen sein... wenn du keinen anderen Fehler eingebaut hast. ;-)
Das Kauf-PlugIn funktioniert wunderbar...

Grüße
Holger

raimondo

Beginner

  • "raimondo" started this thread

Posts: 22

Location: Bad Kreuznach

Occupation: Fotograf

  • Send private message

3

Tuesday, May 4th 2010, 7:04pm

Danke für'n Tip,.. ich glaube ich mußte nur mal ganz raus ausm Browser... hingen wohl noch die alten xml im cache....
scheint zu funktionieren ! Hätte es natürlich lieber etwas eleganter... das sich die map erst beim drücken auf einen halbtransparenten Button entfaltet z.B.

und wie krieg ich eigentlich den Radius vom Radar und vom Bildausschnitt überein ... habe da keinen Parameter zu gefunden !

http://www.raimondophoto.net/Nahetal

ciao !
*tongue*raimondo

4

Tuesday, May 4th 2010, 7:32pm

radar, map-button etc.

Radar: z.B. size="60", damit kannst du die Größe des Radars an deinen Kartenauschnitt anpassen.
Wenn du ein bisschen im Forum stöberst oder dir am besten mal alle Beispiele ansiehst, findest du auch bald eine Menge Beispiele für deinen transparenten Button ;-) . Vieles ist sehr leicht übertragbar.

Viele Grüße
Holger

raimondo

Beginner

  • "raimondo" started this thread

Posts: 22

Location: Bad Kreuznach

Occupation: Fotograf

  • Send private message

5

Thursday, May 6th 2010, 7:57am

Danke Holger,
bin wieder ein bischen weiter gekommen, ein Problem gelöst... kommt ein anderes

www.raimondophoto.net/Nahetal

*squint* raimondo

raimondo

Beginner

  • "raimondo" started this thread

Posts: 22

Location: Bad Kreuznach

Occupation: Fotograf

  • Send private message

6

Friday, May 7th 2010, 5:52pm

*confused* den Botton hab ich...aber die map kommt auch direkt am Anfang und wartet nicht bis der Botton gehovert wird.....
hier der code : <plugin name="mapslogo" url="plugins/Google-small-logo.png" keep="true" align="leftbottom" x="0" y="50" onover="tween(plugin[maps].x,0,0.3,easeoutquad,set(plugin[maps].onout,set(plugin[maps].onout,null);tween(plugin[maps].x,-300);));" zorder="1"/>
<plugin name="maps"
url="plugins/googlemaps.swf"
keep="false"
handcursor="true"
zorder="2" xonover="tween(plugin[maps].x,0);" xonout="tween(plugin[maps].x,-300);"
align="leftbottom"
x="0"
y="80"
width="200"
height="300"
wer kennt sich aus ?

7

Monday, May 10th 2010, 3:03pm

Hi,
den Botton hab ich...aber die map kommt auch direkt am Anfang und wartet nicht bis der Botton gehovert wird.....

die Karte ist zu Beginn sichtbar, da die "Start"-Positionen der Karte im sichtbaren Bereich:

Quoted

<plugin name="maps"
url="plugins/googlemaps.swf"
...
x="0"
y="80"

...
/>
beim "onout" wird "x" auf "-300" geändert,

um die Karte also zu Beginn 'ausgeblendet' zu haben:

Quoted

<plugin name="maps"
url="plugins/googlemaps.swf"
...
x="-300"
y="80"

...
/>

Schöne Grüße,
Klaus

raimondo

Beginner

  • "raimondo" started this thread

Posts: 22

Location: Bad Kreuznach

Occupation: Fotograf

  • Send private message

8

Thursday, May 13th 2010, 5:18pm

um die Karte also zu Beginn 'ausgeblendet' zu haben

ja bestens ! Danke Klaus!!

ciao
raimondo

www.raimondophoto.net/Nahetal

PS : jetzt müßte nur noch gelingen daß man über die Spots zu den jeweiligen Bildern kommt ! *whistling*

Similar threads