You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, August 3rd 2010, 6:50pm

how to add watermark in krpano?

I am not sure under which thread to post. I want to add watermark in high resolution pano. Can it be done in krpano?

Thanks
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

Zephyr

Professional

Posts: 1,003

Location: Netherlands

Occupation: Web developer

  • Send private message

2

Tuesday, August 3rd 2010, 10:24pm

you can make a something in photoshop, add it as a plugin with enabled on false, keep on true, maybe a blending mode. This could be a simple watermark or a text repeated 100 times. This way you can easily remove it.

But if you want to secure your images to make sure they dont get ripped, then you should just add it in the image itself.

What is the reason that you want to watermark it? theft prevention or just marketing?

3

Wednesday, August 4th 2010, 3:19pm

Thanks for the reply. I want to add it to protect the file from other sites using it in iframe or popup window. krprotect only protect domain name. If some one use the swf link to show popup in their site, I want the view to know the origin of the photo site by adding watermark.
Looks like the only way is to use photoshop to add watermark, but for high resolution photos, it will take time to add a few of them.
I am wondering any alternative to it with krpano.
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

Zephyr

Professional

Posts: 1,003

Location: Netherlands

Occupation: Web developer

  • Send private message

4

Thursday, August 5th 2010, 9:21am

Well if you domainprotect it, then they can only use an iframe popup.
You then have like javascripts that prevent your website being in an iframe:

http://usablelayout.com/articles/automat…reak-out-iframe

And you can alsoo add a plugin to your tour

<plugin name="watermark" url="watermark.jpg" keep="true" blendmode="difference" width="100%" height="100%" />
You can even create it with javascript, that when the page is in an iframe, show this watermark, else don't

5

Thursday, August 5th 2010, 7:07pm

Thanks for reply Zephyr. Where can I get that wartermark plugin?

Thanks
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

Zephyr

Professional

Posts: 1,003

Location: Netherlands

Occupation: Web developer

  • Send private message

6

Friday, August 6th 2010, 8:58am

plugin doesnt nessesary mean a flash file or complicated script, it can be an image. So create a watermark in photoshop (type some text on a transparent layer and save as png), and type that code in your xml.

7

Saturday, August 7th 2010, 12:18pm

Thanks, it works like a charm. How can I add weblink on that watermark? It is showing link mouse cursor and can I add web link to it? If there is doc for this please point it to me.

Cheers!
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

This post has been edited 1 times, last edit by "wilcofong" (Aug 7th 2010, 12:34pm)


8

Saturday, August 7th 2010, 4:35pm

Here is the link to your specific request.

http://www.krpano.com/docu/actions/#openurl

and here is the link to all of the documentation current for release 1.0.7 This documentation is still valid but newer features have not yet been added. It is a work in progress.

http://www.krpano.com/docu/

This link is also found at the top of each page of the forum. "Documentation"

9

Saturday, August 7th 2010, 10:44pm

I add openurl code in xml and it does not happened anything. I am making something wrong?


<plugin name="watermark"
url="skin/watermark.png"
keep="true"
blendmode="difference"
width="15%"
height="15%"
align="rightbottom"
onclick="openurl(http://www.krpano.com,_blank);"
/>
http://rootfive.blogspot.com/2010/08/pan…n-blogspot.html
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

Zephyr

Professional

Posts: 1,003

Location: Netherlands

Occupation: Web developer

  • Send private message

10

Sunday, August 8th 2010, 3:09pm

I think its becaue you used krprotect to embed everything in 1 swf. I think there is an option in krprotect, to disable javascript/external parameters. You should uncheck 1 of those (probally javascript)

11

Sunday, August 8th 2010, 4:28pm

Thanks for your reply. I did not check the check box "disable javascript and external interface". I tried it locally without encryption and still it does not work. I mean it does not open new window. Here is my local xml script that I test.


<krpano version="1.0.8">

<include url="skin/defaultskin.xml" />
<plugin name="watermark"
url="skin/watermark.png"
keep="true"
blendmode="difference"
width="15%"
height="15%"
align="rightbottom"
onclick="openurl(http://www.krpano.com,_blank);"
/>
<view hlookat="0" vlookat="0" maxpixelzoom="1.0" />
<display details="22" />

<preview type="CUBESTRIP" url="image.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="579">
<level tiledimagewidth="3183" tiledimageheight="3183">
<left url="image.tiles/l3_l_%0v_%0h.jpg" />
<front url="image.tiles/l3_f_%0v_%0h.jpg" />
<right url="image.tiles/l3_r_%0v_%0h.jpg" />
<back url="image.tiles/l3_b_%0v_%0h.jpg" />
<up url="image.tiles/l3_u_%0v_%0h.jpg" />
<down url="image.tiles/l3_d_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="1592" tiledimageheight="1592">
<left url="image.tiles/l2_l_%0v_%0h.jpg" />
<front url="image.tiles/l2_f_%0v_%0h.jpg" />
<right url="image.tiles/l2_r_%0v_%0h.jpg" />
<back url="image.tiles/l2_b_%0v_%0h.jpg" />
<up url="image.tiles/l2_u_%0v_%0h.jpg" />
<down url="image.tiles/l2_d_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="796" tiledimageheight="796">
<left url="image.tiles/l1_l_%0v_%0h.jpg" />
<front url="image.tiles/l1_f_%0v_%0h.jpg" />
<right url="image.tiles/l1_r_%0v_%0h.jpg" />
<back url="image.tiles/l1_b_%0v_%0h.jpg" />
<up url="image.tiles/l1_u_%0v_%0h.jpg" />
<down url="image.tiles/l1_d_%0v_%0h.jpg" />
</level>
</image>

</krpano>

Thanks for all your help.
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

Zephyr

Professional

Posts: 1,003

Location: Netherlands

Occupation: Web developer

  • Send private message

12

Sunday, August 8th 2010, 5:17pm

You are having an security issue. Flash doesn't allow linking to external pages offline (you have to add your drive to the trusted list).

It should work online however. But it doesn't probably because you either disabled javascript/external parameters in your embedded swf, or you don't give the right properties to flash in the html file.

From what I see, you also link to the SWF directly (without using swfobject). So you don't have the property allowscriptaccess to flash). Never link to an swf file directly but rather link to an html file with swf in it (preferable using the SWFobject, krpano droplets should already provide you an html file and javascript to do so).

swf.addParam("allowscriptaccess", "always");

This post has been edited 1 times, last edit by "Zephyr" (Aug 8th 2010, 11:28pm)


13

Sunday, August 8th 2010, 5:49pm

Thanks Zephyr. I upload the whole html to web directory and it works. Thanks for your taking time to reply.

Regards,
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
my blog: http://mycasualsnaps.blogspot.com
my website: http://www.brac360.ky
=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=

This post has been edited 1 times, last edit by "wilcofong" (Aug 8th 2010, 7:37pm)


14

Tuesday, April 24th 2018, 7:56am

Source code

1
2
3
4
5
6
7
8
9
10
11
<!-- watermark -->
<plugin name="watermark"
url="/tour_icons/watermark/watermark.png"
keep="true"
blendmode="difference"
width="100%"
height="100%"
align="rightbottom"
enabled="false"
/>
<!-- watermark -->

this is image :http://www.realstockphotos.com/assets/wa…s/watermark.png

<img src="http://www.realstockphotos.com/assets/watermarks/watermark.png" alt="watermark.png" title="watermark.png" style="font-size: 0.8em;" />