You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jerzksa

Beginner

  • "jerzksa" started this thread

Posts: 5

Location: Poland

  • Send private message

1

Sunday, August 15th 2010, 10:56pm

Gallery in Virtual Tour

Hi Masters, I have one problem with picture gallery. At the page http://sarota.net/panoramy/rover/back/ witch is last subpage of virtual tour I have gallery. But when I enter to this subpage through main adress http://sarota.net/panoramy/rover/front/ gallery is lost. Did I something wrong? Is it possible to setup other pictures on other subpages ? Here is xml http://sarota.net/panoramy/rover/back/index.xml


Best Regards Jerzy

This post has been edited 1 times, last edit by "jerzksa" (Aug 17th 2010, 7:12pm)


2

Wednesday, August 18th 2010, 10:09am

Hi,

edit the "thumbbar.xml" and search there for the green marked lines and add the red marked ones below:

Quoted

addplugin(thumbbar);
set(plugin[thumbbar].keep,true);

addplugin(get(pname));
set(plugin[%pname].keep,true);
then the thumbbar with the thumbs will be kept when loading the next pano,

best regards,
Klaus

3

Tuesday, October 26th 2010, 11:14pm

include gallery in the tour

dear Klaus,

I tried to integrate the gallery like Jerzy did here http://sarota.net/panoramy/rover/back/
http://sarota.net/panoramy/rover/back/index.xml

but it just not works. I get no error, but it does not show me any thumbnails neither.
so I tried it like that:

<krpano version="1.0.8">
<include url="imagegallery.xml" />

<view
hlookat="0"
vlookat="0"
fov="65"
fovmax="60"
fovmin="10"
fisheye="0.0"
fisheyefovlink="0.5"
limitview="lookat"
vlookatmin="0"
vlookatmax="0"
/>

<preview type="CUBESTRIP" url="03_kreuzung.tiles/preview.jpg" />
<image type="SPHERE" multires="true" tilesize="1250" baseindex="1">
<level tiledimagewidth="10000" tiledimageheight="5000" details="20">
<sphere url="03_kreuzung.tiles/l2_%v_%h.jpg" />
</level>
<level tiledimagewidth="5000" tiledimageheight="2500" details="30">
<sphere url="03_kreuzung.tiles/l1_%v_%h.jpg" />
</level>
</image>
</krpano>


--------------------------------------------------------------------------------------
and the _imagegallery.xml looks like that:

<!--
krpano 1.0.8
- a xml driven image gallery example
- click a small image to view it large
-->

<krpano version="1.0.8" onstart="start();">

<!-- text style for startup text -->
<textstyle name="infostyle"
origin="center" edge="center" yoffset="-100" textalign="center" background="false" border="false"
fontsize="40" textcolor="0xFFFFFF" bold="false" effect="glow(0xFFFFFF,0.7,4,2);glow(0x000000,1,4,2);dropshadow(3,45,0x000000,2,0.6);"
showtime="4.0" fadeintime="1.0" fadetime="1.0"
/>


<!-- include image thumbbar xml script code -->
<include url="thumbbar.xml" />


<action name="start">
showtext('krpano[br]xml image gallery example', infostyle);

<!--
syntax:
create_thumbbar(numberofimages, align, orientation, x,y, width,height, border);

numberofimages ... number of images
align ... position of the imagebar (lefttop,left,leftright,top,center,bottom,righttop,right,bottom)
orientation ... orientation of the imagebar (h or v)
x,y ... position offsets
width,height ... thumbnail imagesize
border ... border around images
-->
create_thumbbar(4, left, v, 10,10, 90,60, 6);

thumbbar_addimage('images/1.jpg');
thumbbar_addimage('images/2.jpg');
thumbbar_addimage('images/3.jpg');
thumbbar_addimage('images/4.jpg');

</action>
</krpano>



As you notice, I just tried it as it is explained on the krpano page - I hope you can help?

best regards,
matt

4

Tuesday, October 26th 2010, 11:55pm

include gallery in the tour

I just realized that if I use this code in the First Pano of the Tour, it works. But I do need the gallery not in the first Pano of the Tour.

how do I have to change this code:

<krpano version="1.0.8" onstart="start();">
<include url="imagegallery.xml" />

that it includes the thumbs when the Pano is loaded?

best regards,
matt

Tuur

Sage

Posts: 3,128

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

5

Wednesday, October 27th 2010, 12:27am

edit.. sorry i was wrong and stupid.. ;-P
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 1 times, last edit by "Tuur" (Oct 27th 2010, 3:23am)


6

Wednesday, October 27th 2010, 9:30am

I tried now also to include it directly like Tuur did it:
------------------------------------------------------------------------------------------
<krpano version="1.0.8" onstart="start();">

<include url="thumbbar.xml"/>

<action name="start">

<!--

syntax:
create_thumbbar(numberofimages, align, orientation, x,y, width,height, border);

numberofimages ... number of images
align ... position of the imagebar (lefttop,left,leftright,top,center,bottom,righttop,right,bottom)
orientation ... orientation of the imagebar (h or v)
x,y ... position offsets
width,height ... thumbnail imagesize
border ... border around images

-->

create_thumbbar(4, bottom, h, 0, 0, 90,70, 8);
thumbbar_addimage('images/1.jpg');
thumbbar_addimage('images/2.jpg');
thumbbar_addimage('images/3.jpg');
thumbbar_addimage('images/4.jpg');

</action>

------------------------------------------------------------------------------------------

but it does not work neither.
so.. I am still wrong and stupid - may somebody bring enlightment to my brain ? :)

7

Friday, October 29th 2010, 2:37pm

include gallery in the tour - solved

I solved this problem. ... although I guess there are more simple ways to do it...

- thats how I did it:

Source code

1
2
3
4
5
6
   <include url="images_mobile2.xml" />
<action name="load36">
loadpano(36_mobile_home_02a.xml,null,KEEPPLUGINS,BLEND(2));
hide();
images_mobile2();
</action>


It was not possible to call the images_mobile.xml from the "36_mobile_home_02a.xml"
So the code above is in the main xml file
The action "images_mobile2();" calls an xml file with this content (adding your images to the thumbbar):

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
 <action name="images_mobile2">
<!--showtext('[b][i]krpano[br]xml image gallery example[/i][/b]', infostyle);-->

<!--
syntax: 
create_thumbbar(numberofimages, align, orientation, x,y, width,height, border); 

numberofimages ... number of images
align      ... position of the imagebar (lefttop,left,leftright,top,center,bottom,righttop,right,bottom)
orientation... orientation of the imagebar (h or v)
x,y        ... position offsets
width,height   ... thumbnail imagesize
border     ... border around images
-->
create_thumbbar(4, bottom, h, 10,10, 90,60, 6);

thumbbar_addimage('images/mobile2/1.jpg');
thumbbar_addimage('images/mobile2/2.jpg');
thumbbar_addimage('images/mobile2/3.jpg');
thumbbar_addimage('images/mobile2/4.jpg');

tween(plugin[thumbbar].alpha, 1);
tween(plugin[thumbbar_image_0].alpha, 1);
tween(plugin[thumbbar_image_1].alpha, 1);
tween(plugin[thumbbar_image_2].alpha, 1);
tween(plugin[thumbbar_image_3].alpha, 1);

set(plugin[thumbbar_image_0].enabled, true);
set(plugin[thumbbar_image_1].enabled, true);
set(plugin[thumbbar_image_2].enabled, true);
set(plugin[thumbbar_image_3].enabled, true);


</action>


the "hide();" action hides all the other thumbnail bars (or the thumbnail bar that was opened before):

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<action name="hide">

tween(plugin[thumbbar].alpha, 0,1);
tween(plugin[thumbbar_image_0].alpha, 0,1);
tween(plugin[thumbbar_image_1].alpha, 0,1);
tween(plugin[thumbbar_image_2].alpha, 0,1);
tween(plugin[thumbbar_image_3].alpha, 0,1);
tween(plugin[thumbbar_image_4].alpha, 0,1);


set(plugin[thumbbar_image_0].enabled, false);
set(plugin[thumbbar_image_1].enabled, false);
set(plugin[thumbbar_image_2].enabled, false);
set(plugin[thumbbar_image_3].enabled, false);
set(plugin[thumbbar_image_4].enabled, false);

</action>



hope this helps :)

This post has been edited 5 times, last edit by "mattk" (Oct 31st 2010, 5:26pm)