You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Run

Beginner

  • "Run" started this thread

Posts: 41

Location: maryland. USA

Occupation: Photographer

  • Send private message

1

Monday, September 6th 2010, 7:36pm

Doing something wrong with Kprotect, need help.

Hello,
I am trying to kprotect a panorama for the first time and am sure I am doing something wrong. Whenever I try to run the final swf created by Kprotect I get the following error;
ColumnsP.xml - Loading Error (IO Error)

I have the following files in this folder structure;
**********************************************
CollumsKr (Main Folder)
Columns.html (generated by Droplet)
Columns.jpg (equirectangular used to make Panorama)
Columns.swf
skin (Sub-Folder)
controlmenuV3-LPnotext.swf
drag-cursors.png
logo_spin.png
qtvr-cursors.png
***************************************************
The panorama was generated by dropping the Columns.jpg on "MAKE PANO (SINGLE-SWF) droplet.bat" droplet. Which created the Columns.swf and the Columns.html files.

I then ran Kprotect.exe and set a domain limit to "domain.com" and set each of the following files to be embedded;
Columns.swf
controlmenuV3-LPnotext.swf
drag-cursors.png
logo_spin.png
qtvr-cursors.png
I set the name of the new protected file to be ColumnsP.swf and changed the name in the html file to load the protected swf. When I open the columns.html in a browser I get the Load error above telling me it cant load the columnsP.xml. The thing I don't understand is, isn't the xml embedded into the swf when making a singleswf panorama? And if that is the case where do I tell kprotect.exe to find the columnsP.xml? *confused*


Sorry if I am missing something very obvious, I have been trying to figure it out for myself for two days but I cant seem too, any help would be greatly appreciated, even if its "Hey Stupid, you should have done this" *rolleyes* .
Thank you
Rick
P.S. I had previously added and installed my licenses using the setup menu prior to this in kprotect.exe.

2

Monday, September 6th 2010, 8:43pm

I don't use the pano (single-swf) but I understand it to be used when you don't plan to use kprotect. It embeds your license and XML file into the swf. That said, if you plan to use protect use a .bat without swf. ( I may be wrong, so take this with a grain of salt)

Back to your issue, by renaming the swf, you are making it look for the columnsP.xml file which you do not have. Putting the initial name should allow it to work since the Column.xml file is in the swf.

Hope this provides some insight to your issue.

Run

Beginner

  • "Run" started this thread

Posts: 41

Location: maryland. USA

Occupation: Photographer

  • Send private message

3

Monday, September 6th 2010, 10:20pm

Jarredja,

Thank you for your help.

To be honest I am totally confused now. I got rid of the singleswf and started
using the Shortcut to “MAKE PANO (TILED) droplet.bat” which does not create a
swf file as you suggested. Just to make sure I am not botching this up some
where along the line I have outlined each step I am taking so it can be
critiqued.

I started with the following folders and contents;
*******************************************************
FOLDER CollumsKr
FILE Columns.jpg Equirectangular Image)

FOLDER Plugins (These are not being used)
FILE editor.swf
FILE options.swf
TOTAL Plugins\

FOLDER skin
FILE buttons.png
FILE controlmenuV3-LPnotext.swf
FILE defaultskin.xml
FILE drag-cursors.png
FILE logo_spin.png
FILE qtvr-cursors.png
FILE Thumbs.db
TOTAL skin\

********************************************************

I then dropped the columns.jpg onto the “MAKE PANO (TILED) droplet.bat”
Which created the following folder/file structure;
***************************************************
FOLDER CollumsKr
FILE Columns.html
FILE Columns.jpg
FILE Columns.xml
FILE krpano.license
FILE krpano.swf
FILE swfkrpano.js


FOLDER Columns.tiles
FILE b_01_01.jpg
~
FILE u_03_03.jpg
TOTAL Columns.tiles\

FOLDER Plugins (These plugins are not being used or embedded)

FILE editor.swf
FILE options.swf
TOTAL Plugins\

FOLDER skin (These are all added by embedding through Kprotect)

FILE buttons.png
FILE controlmenuV3-LPnotext.swf
FILE defaultskin.xml
FILE drag-cursors.png
FILE logo_spin.png
FILE qtvr-cursors.png
FILE Thumbs.db
TOTAL skin\
************************************************************************
I then started Kprotect.exe and first thing selected “New”, went to the setup
drop down menu and selected “Register krpano licenses” selected install for
all.

I then selected the protect tab and added a domain “domain.com” saved the project
and went to the embed tab.

I embedded all of the following; folders “columns.tiles” and “skin” and these
files columns.xml and krpano.swf.

Now here I am not sure what to do, should I generate the protected file as
columns.swf or overwrite the krpano.swf with this protected one?

Also, what files should I see added to this folder structure and what files would I upload
to my server for this all to work properly after it is all generated?

Thank you very much for your help.

Rick

Run

Beginner

  • "Run" started this thread

Posts: 41

Location: maryland. USA

Occupation: Photographer

  • Send private message

4

Monday, September 6th 2010, 11:13pm

I got it working thanks, just had to embed the startup xml and save the results into a another folder.
Thanks much
Rick