You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, February 28th 2009, 11:48am

Protecting your XML and your business...

Is there any way that a user can protect their XML code - i.e. obfuscate it?

I find I do a significant amount of coding, then it's just there for anybody to "borrow" or examine... any way to help keep trade secrets protected?

I'm not suggesting a closed door on sharing code, specifically in a forum such as this; but, it would be nice to keep a client from taking your code and then deciding they don't need your services any longer...

2

Saturday, February 28th 2009, 3:14pm

Hi,

there is a new "kprotect - krpano protect tool" gui tool for exactly this

http://krpano.com/forum/wbb/index.php?pa…ad&threadID=331

download it here:
http://krpano.com/download/beta/

at the moment only the first xml can be embedded, but if reorganize the xml's
nearly all can be done in one xml,

with the next version (beta 7) - any additional file (xml, buttons, panos, ...) can be embedded or encrypted too

best regards,
Klaus

3

Saturday, February 28th 2009, 7:19pm

Unbelievable timing - this is GREAT! Can't wait for the final... Thanks Klaus!

4

Sunday, March 1st 2009, 2:18am

This is EXCELLENT! It works perfectly locally, but I get a LICENSE ERROR when I put it online... I only selected the Embedded XML option, and did not select Limit Domains... any idea how to eliminate the License Error?

5

Tuesday, March 3rd 2009, 12:02am

This is EXCELLENT! It works perfectly locally, but I get a LICENSE ERROR when I put it online... I only selected the Embedded XML option, and did not select Limit Domains... any idea how to eliminate the License Error?
Hi, sorry, there was a small bug in the kprotect tool - the limit domain option was always on
(even when it wasn't checked and there were no domains in the list)

but this bug is fixed now, place download the tool again, now it should work

best regards,
Klaus

6

Thursday, March 12th 2009, 10:27am

Hi Klaus !
When I start krprotect it doesn't found neither my krpanotools.licence nor krpano.licence, while they are both in the folder :( ...
Thanks
Regards

7

Thursday, March 12th 2009, 10:13pm

Hi,

that's strange, the tool looks normally in the current directory or in the directory
where to tool itself stays for the license files,

which system do you use? window/mac? it is a normal folder?

but you can select to paths to the license file also manually:
- by dropping the license files onto the setup tab
- or by using the "Browse.." button

best regards,
Klaus

8

Thursday, March 12th 2009, 10:32pm

I changed my folder and came back to the former one, and it works
(I'm work on mac os x with a ntfs HD)
It's ok, now
Sorry for my disturbing you... *unsure*

Similar threads