You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, February 28th 2009, 5:30pm

Replacing jpg buttons with swfs

As the title says: How can I replace the little jpeg on-screen nav buttons with nice animated swfs ? I have tried all the obvious things with Z order, size, names, %SWFPATH% etc but nothing appears. Is there a simple answer ?

(Sorry to ask so many questions!)

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

2

Saturday, February 28th 2009, 5:50pm

should be able to just replace the url --> jpg with the url pointing to the swf that you want to use.

http://www.krpano.com/docu/xml/#plugin

can you post a sample of your code?

3

Sunday, March 1st 2009, 1:02am

I thought I could just do a straight swap too, but no luck. I have tried many permutations and different swfs.

In the code below if I swap the left.swf for left.jpg it works perfectly !

Source code

1
2
3
4
5
6
7
8
9
10
<plugin name="flash" 
    	url="left.swf" 
    	width="100" height="100"
 	visible="true" enabled="true" handcursor="true" capture="true" children="true"
 	zorder="0"
 	alpha="1.00" blendmode="normal"
    	align="rightbottom" x="10" y="10"
    	onhover="showtext(Flash element);" 
    	onclick="openurl(http://krpano.com,_blank);" 
    	/>

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

4

Sunday, March 1st 2009, 2:08am

In the 1.0.7 stable release, under examples / tour... there is a hotspot_ani.swf... so it's guaranteed to be compatible with krpano... try it also.

The only other thing that you might want to add first... is...

keep="true"...

but if the jpg file is showing... then the swf should show as well without it.

I've tested the code you posted and made only two changes...
1. using the hotspot_ani.swf
2. added keep="true"

The second one is more specifically for how I have my test template setup... I do not load a pano initially... only after clicking on a button will the first pano load.... thus I NEED to have keep true in place otherwise it dumps the plugin.

5

Sunday, March 1st 2009, 8:39am

You've rescued me again Graydon, thanks :-)