You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,113

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Wednesday, November 10th 2010, 5:27pm

Cubefaces line up

He Klaus,

i see problems with the cube faces ... they not fit correct..

you can see it here at the chair... on iphone mode (on the desktop ) it makes a wrong connection to the other cubeface..
in normal mode it's oke..

http://www.virtualtuur.com/lobbes/1/


in the next example you can see the same at the celing..

http://www.virtualtuur.com/lobbes/2/

grtz

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

2

Wednesday, November 10th 2010, 5:31pm

Hi,

this was fixed in the current (1.0.8.12) version,

best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,113

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

3

Wednesday, November 10th 2010, 5:36pm

I thought this is 12 ... not.. sorry..

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

4

Monday, November 29th 2010, 5:23pm

hi,
well i'm using the latest krpano release from 24/11/2010 ,
and with html5 version ,
the same page look ok with cubefaces correctly aligned in ipad/ipod but misaligned in safari emulating idevices user-agent,
any ideas ??

thanks

z

5

Wednesday, December 1st 2010, 11:44am

Hi,

can you show an example/link?

best regards,
Klaus

6

Wednesday, December 1st 2010, 1:40pm

ok i PM you the link *smile*
(i simplified the source and archived in zip)

z

7

Wednesday, December 1st 2010, 2:08pm

Hi,
(i simplified the source and archived in zip)
in your xml the image size is defined as 1900x1900:

Source code

1
<level tiledimagewidth="1900" tiledimageheight="1900">


but the real image size is 2200x2200, this cases this effect,

with the Flash10 renderer this wrong setting will be become visible
because there relative coordinates were used (0.0 to 1.0) instead
of absolute pixel coordinates,

but in krpanoJS and also in the Flash9 renderer absolute pixel coordinates
were used and there the panos looks wrong,

e.g. you can see the problem also in Flash - open the pano,
press first the 'O' key to open the log and then press '9' to
switch to the Flash9 renderer, the pano will look the same
like in the krpanoJS viewer,

to fix it - just use the right size in the xml,

best regards,
Klaus

8

Wednesday, December 1st 2010, 2:15pm

oh thanks...
i remember have done some try with modifying the size of cubefaces now....

hopefully that's not a bug *smile*

z

PS : should mark this thread as SOLVED

SUM-UP : to fix this, use latest version of krpano and check out dimensions of your cubefaces (if they match .xml declaration)

This post has been edited 1 times, last edit by "zadda" (Dec 1st 2010, 2:47pm)