You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, November 11th 2010, 8:17pm

disabling errors and O key does not work with 1.0.8.12

Dear friends,


I'm trying to disable errors and O key with Krpano version 1.0.8.12 and it just does not work.

I've read a few posts that links to XML documentation link in order to see how to disable O key, but there is no entry on documentation about it.
I've placed <krpano version="1.0.8" logkey="false"> at default.xml and also in root xml pano and I keep on seeing the O key and errors.

How can I disable errors and the O key messages? I managed to disable TAB key with new krpano.swf but errors and O key, it's just not possible and when clients type in their names and emails in contact form in flash, the license message keeps on appearing on and on when the O key is pressed.

Can you help me and tell me which code and where exactly do I have to place it? I'm using 1.0.8.12

Thanks in advance.
Alfonso

2

Friday, November 12th 2010, 6:40am

I didn't know you could disable it, its fine to see that error when you are developing the tour but its irritating when clients see those errors & complain about it.

3

Friday, November 12th 2010, 7:05am

The logkey="false" worked fine for me to stop the o button but I don't have the setup you seem to have with the form. Try using both of these together, maybe it will solve your problem???


logkey="false" showerrors="false"

4

Friday, November 12th 2010, 8:58am

Hi,

as additional note - the logkey="false" - and - showerrors="false" -
must be in the first loaded xml file,

about logkey="false" - this will just disable the key itself, but without showerrors="false" errors will still open the log,

and - when there are errors they should be better fixed instead of suppressed

best regards,
Klaus

5

Friday, November 12th 2010, 1:51pm

Thanks for your kind replies!

I've tried you told me Klaus, and it doesn't work either.

I've KRPano 1.0.8.12, and let me tell you what I did, since I don't know what you mean with "first loaded xml", I guess it's default.xml, but I tried with it and also with the first pano.xml from first tour loaded

I added this line of code to default.xml and it didn't work, I added it as well to the first pano.xml loaded and it doesn't work. I tried both xml files with this code and also separatedly, but no success. When I press the O key I see my license text at the bottom

<krpano version="1.0.8" logkey="false" showerrors="false">


What am I doing wrong?
Thanks in advance!

Warm regards,
Alfonso

6

Friday, November 12th 2010, 2:02pm

Can you describe the steps you took to make your panos? As in which tool did you use? What did you do after that? Can you also provide a link?

7

Friday, November 12th 2010, 2:24pm

Thanks for your reply!

I've reinstalled krpano 1.0.8.12 completely, maybe I had mixed some files because I was using the demo files from an older krpano version and I bought license last week. I uploaded all again, and it looks like it's working now :) The O keyboard does not trigger the licence message, thanks god! :)

You can see the link I was talking about here:
http://www.elbalcondeohanes.com/

It's a custom application we've made for a client, with 2 languages (though we can provide as many as needed), menu navigation, independent music for each pano or group of panos, custom popups, and some other customizations we've made for him.

Thanks Klaus for your reply, and even MANY MORE THANKS for having created such a piece of work of art that KRPano is!

Warm regards,
Alfonso