You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Paranorma

Beginner

  • "Paranorma" started this thread

Posts: 20

Location: Russia, St.Petersburg

  • Send private message

1

Monday, November 15th 2010, 4:13pm

Oninterrupt(); action does not work with 1.0.8.12

Hi!
Why oninterrupt() action does not work with 1.0.8.12? In version 1.0.8.11 this code working fine (when mouse click):

Source code

1
2
3
4
5
6
 	oninterrupt( 
 		set(plugin[myplugin].enabled, false);
 		action(any action1);
 		action(any action2);
 		breakall();
 	);

In version 1.0.8.12 - no reaction

Paranorma

Beginner

  • "Paranorma" started this thread

Posts: 20

Location: Russia, St.Petersburg

  • Send private message

2

Tuesday, November 16th 2010, 12:18pm

definition: this bug occur when run auto_tour action. For example:

Source code

1
2
3
4
5
6
7
8
9
<action name="auto_tour"> 
oninterrupt( 
action(...);
breakall();
); 
set(i,0);
autotour_next(get(i));

</action>
In version 1.0.8.12 - mouse click - not respond (not break action). In version 1.0.8.11 - working ok!
I found difference:
oninterrupt(); code now must be inserted in body loop action (autotour_next) - in this case interrupt working fine. Problem solved.

3

Wednesday, November 17th 2010, 2:02pm

Hi,

right, the oninterrupt functionality has changed a bit,
now only the following actions after the oninterrupt where stopped instead of just everything,
this was necessary to be able to use animations (like the action hotspot animations) together with oninterrupt,
(btw - sorry, I see I have forgotten to note that in the releasenotes.txt),

best regards,
Klaus