You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,387

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Sunday, January 9th 2011, 12:30pm

infostyle / text onload problem

Hi,

i think i make a stupid mistake somewhere..

I like when you click on a thumb that it shows some text when the pano loads in the right top.
(i have ths working somewhere else.. no problems..)

At the first pano it works but with al the others it just flashes quick...

http://www.virtualtuur.com/vosbergen/

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<action name="load1">

    	set(plugin[spotx].x,140);
    	set(plugin[spotx].y,340);
    	set(plugin[radar].x,140);
    	set(plugin[radar].y,340);
    	loadpano(1.xml,null,MERGE,BLEND(1));
		showtext('test a', infostyle);	
		set(plugin[radar].heading,270);
		</action>


<textstyle name="infostyle"
	           origin="righttop" edge="top" yoffset="2"  xoffset="40" textalign="center"  background="false" border="false"
	           fontsize="18" font="Verdana" textcolor="0xFFFFFF" bold="false" effect="glow(0xFFFFFF,0.2,4,2);glow(0x000000,1,4,2);dropshadow(2,45,0x000000,2,0.6);"
	           showtime="5.0" fadetime="1.0"
	           />


any idea?

Thanx

Tuur *thumbsup*

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,387

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Sunday, January 9th 2011, 2:24pm

is it possible that it goes wrong in the gallery? with something?

http://www.virtualtuur.com/vosbergen/nl/gallery.xml

??

when i hover a thumb the infostyle text disapears... *question* *confused*

Tuur

This post has been edited 1 times, last edit by "Tuur" (Jan 9th 2011, 3:44pm)


jpdeglet69

Intermediate

Posts: 212

Location: France

Occupation: VR Maker and Document Management Expert

  • Send private message

3

Thursday, January 13th 2011, 10:48am

Hi,

To do the same, I use textfield plugin because
"showtext() : show a text message on the screen.
- only one text can be shown at one time! When calling showtext again the current shown text will be removed!"
Best regards,
JPhD
VR-GuideĀ®/Eleana CEO
https://vr-guide.online

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,387

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

4

Thursday, January 13th 2011, 11:46am

Oke Thanks,

Now i need to write it in this scrolling thumbs xml...

let's have a try..
Tuur *thumbsup*