You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, January 10th 2011, 8:10am

Ipad Question

Hello,

In my directory there are the following files:

krpanoiphone
krpanoiphone.license
krpanotools.license

But.....there is no iPadversion made?

Please help.

Thanks

Tuur

Sage

Posts: 3,160

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Monday, January 10th 2011, 1:52pm

don't worry,
this license does all.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

VN2009

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

3

Monday, January 10th 2011, 2:58pm

check your config file makes sure it is set to actually build the idevice tiles. if it is set to auto it should just be looking for the license you say is already in the right spot.

4

Monday, January 10th 2011, 4:24pm

Please help!!!!
On the server I placed the ' swfkrpano.js '
I made a multires panorama....
Is there a simple manual for me.

Thanks in advance



Here is my xml file:

<krpano version="1.0.8">
<include url="skin/defaultskin.xml"/>
<view hlookat="-180" vlookat="-19" fovtype="MFOV" fov="103" maxpixelzoom="3.0" fovmax="100"/>
<display details="100"/>
<preview url="test.tiles/preview.jpg"/>

<image type="CUBE" multires="true" tilesize="636" progressive="false">

<level tiledimagewidth="955" tiledimageheight="955">
<left url="test.tiles/l1_l_%0v_%0h.jpg"/>
<front url="test.tiles/l1_f_%0v_%0h.jpg"/>
<right url="test.tiles/l1_r_%0v_%0h.jpg"/>
<back url="test.tiles/l1_b_%0v_%0h.jpg"/>
<up url="test.tiles/l1_u_%0v_%0h.jpg"/>
<down url="test.tiles/l1_d_%0v_%0h.jpg"/>
</level>

<mobile>
<left url="test.tiles/mobile_l.jpg"/>
<front url="test.tiles/mobile_f.jpg"/>
<right url="test.tiles/mobile_r.jpg"/>
<back url="test.tiles/mobile_b.jpg"/>
<up url="test.tiles/mobile_u.jpg"/>
<down url="test.tiles/mobile_d.jpg"/>
</mobile>

<tablet>
<left url="test.tiles/tablet_l.jpg"/>
<front url="test.tiles/tablet_f.jpg"/>
<right url="test.tiles/tablet_r.jpg"/>
<back url="test.tiles/tablet_b.jpg"/>
<up url="test.tiles/tablet_u.jpg"/>
<down url="test.tiles/tablet_d.jpg"/>
</tablet>
</image>
</krpano>

This post has been edited 2 times, last edit by "Bonoman" (Jan 11th 2011, 4:44pm)


5

Wednesday, January 12th 2011, 3:16pm

Hi,

there is no need for a special "ipad" file,
the name of the viewer and the license is iphone but it works for iphone and ipad (and optionally also for safari/chrome on desktop),

please show a link to your page or your html file?

btw - you don't need the tools license online, that should be only in the tools folder!

best regards,
Klaus

6

Thursday, January 13th 2011, 7:45pm

Hi Klaus,

Here is the html:

<!DOCTYPE html>
<html>
<head>
<title>krpano.com - test</title>
<meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />
<style>
html { height:100%; }
body { height:100%; overflow: hidden; margin:0; padding:0; font-family:Arial, Helvetica, sans-serif; font-size:16px; color:#FFFFFF; background-color:#000000; }
a{ color:#AAAAAA; text-decoration:underline; }
a:hover{ color:#FFFFFF; text-decoration:underline; }
</style>
</head>
<body>

<script src="test.js"></script>

<div id="pano" style="width:100%; height:100%;">
<noscript><table style="width:100%;height:100%;"><tr style="valign:middle;"><td><div style="text-align:center;">ERROR:<br/><br/>Javascript not activated<br/><br/></div></td></tr></table></noscript>
<script>
embedpano({swf:"test.swf", xml:"test.xml", target:"pano"});
</script>
</div>

</body>
</html>

The xml file is allready in this post. What is wrong???

Regards,

Marcel

7

Thursday, January 13th 2011, 7:50pm

Do you have a link? Does it only not work on an iPad? How about on a iPhone?

8

Thursday, January 13th 2011, 8:59pm

Not on iphone either *angry*

9

Thursday, January 13th 2011, 9:16pm

Since you won't show a link, what type of error are you getting?

10

Thursday, January 13th 2011, 9:23pm

ERROR:

IPhone/iPad version not availlable

11

Thursday, January 13th 2011, 10:35pm

You said you had uploaded the "swfkrpano.js " but your html calls for "test.js" Did you just rename the swfkrpano.js or did you upload the one from the folder that was created with the tools? Are you certain you had the iphone license in the tools folder when the js file was created? If you are not, make sure your licenses are in the tools folder and rerun the tools using the "test" image. Then upload the test.js and test.swf for good measure. It should work since everything else "seems" to be correct.


Jarred

12

Saturday, January 15th 2011, 12:21am

Here is the link, the picture is bad, but that is not issue.....

Thanks in advance,

Marcel

http://www.infotographic.nl/rotterdam360…_Panorama1.html

13

Saturday, January 15th 2011, 10:34am

What I do:

Make cubes from a panorama (Convert SPHERE to CUBE (JPEG) droplet)
Make a Pano Multires with the droplet (MAKE PANO (MULTIRES) droplet)
Publish including: swfkrpano.js, krpanoiphone.js in the webdirectory


Marcel

This post has been edited 1 times, last edit by "Bonoman" (Jan 15th 2011, 8:51pm)


14

Monday, January 17th 2011, 9:15am

Hi,

it looks like that you have used the MAKE PANO (SINGLE-SWF-MULTIRES) droplet,
because the xml is embedded into the swf and there is no other xml file,
that will not work on the iPhone/iPad of course,

try to make sure that you use the MAKE PANO (MULTIRES) droplet,

best regards,
Klaus

15

Monday, January 17th 2011, 2:04pm

Hi Klaus,

I embedded the xml file to protect the license. The pano is definitely a multires (http://www.infotographic.nl/Rotterdam_Panorama1.tiles/ here are files like: tablet_u.jpg, mobile_u.jpg, l1_r_01_01.jpg, l2_r_01_01.jpg. It drives me crazy *angry*

16

Monday, January 17th 2011, 5:05pm

I embedded the xml file to protect the license.


If you are using 1.0.8.12, as long as your licenses are in the tools folder when you use the make pano(multires).bat (NOT THE ONE WITH a SWF in the title),
it will generate all the files you need with your license embedded for you.

For example, I dropped a file named test.tif onto the make pano(multires).bat.

It outputted two folders

test.tiles
skin

and then it outputte the following files.

test.html
test.js
test.swf
test.xml

With these files, it works for me on iPhone.




Jarred

17

Monday, January 17th 2011, 11:34pm

Jarred,

Thanks for your help. I followed your instructions at work on a Windows Pc, And guess what...It works.
At home at my Mac, it doesn't work.
There is a difference in the image output. On the Windows Pc there are 6 jpg files for Flash, 6 for iPad and 6 for iPhone.
On the mac there are 6 for iPad, 6 for iPhone and 294 (?) for Flash. Something is going wrong on my Mac.

Thanks,

Marcel

18

Monday, January 17th 2011, 11:48pm

Make pano(normal).bat should make 6 for each platform but when using make pano(multires).bat , it should have several tile images for the flash version. That is what makes the multires work.

19

Tuesday, January 18th 2011, 12:19am

I think i have to run Windows on a virtual machine on my mac to make it work *thumbdown* *confused*

Made in Windows (http://www.infotographic.nl/test3/verhoek.html)

Made on the Mac (http://www.infotographic.nl/test/)

20

Tuesday, January 18th 2011, 12:24am

Many people use Macs so I am sure it can be done. Maybe someone can give a brief summary of how to use the bat files if they behave differently on a Mac.

Good Luck,

Glad you were able to get some resolution to your problem.

Jarred

Similar threads