You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

1

Thursday, March 31st 2011, 3:07pm

iPhone 3G and iPhone 4G

Hello,

Is it normal that the quality on an iPhone 3G and an iPod Touch 4G are so different ?
I know that the iPod Touch 4G has a retina display but the quality on the 3G is really bad...
Is it a setting that I should add ..?




2

Thursday, March 31st 2011, 3:27pm

As I understand it, the 4 uses the tablet images while the 3G and 3Gs use the mobile images.

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

3

Thursday, March 31st 2011, 3:30pm

As I saw in this conversation I guess you're right ...

And that might also be the reason why on the 4G sometimes the tours don't work always that well...
Safari often turns off.. *thumbdown*
Images to heavy ?

cheers,
=servaas=

HansNyb

Professional

Posts: 936

Location: Denmark

Occupation: Photographer

  • Send private message

4

Thursday, March 31st 2011, 4:05pm

It should actually work better than on iPad 1.
Iphone 4 has 512mb Ram just like the new iPad 2

The problem with iPad 1 is that it just have 256mb and that might give memory problems even If I must say that KRPano performs very well.
The only crashes I sometimes have is if I go Fullscreen on the first pano I see.

After reloading I never see crashes.

There must be something wrong with your iPhone 3. Or maybe you have forgotten to make the 512 mobile images.
It looks to me that it uses the preview.

Hans

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

5

Thursday, March 31st 2011, 4:26pm

The problem might be the 512 mobile images.
I made the tour with the MAKE VTOUR (MULTIRES) droplet, so I thought this took care of that.

But now that I've got a closer look I see that it only made 1432 and 716 images....

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
<image type="CUBE" multires="true" tilesize="716" progressive="false">
			<level tiledimagewidth="1432" tiledimageheight="1432">
				<left  url="kmr1_bdkmr.tiles/l2_l_%0v%0h.jpg" />
				<front url="kmr1_bdkmr.tiles/l2_f_%0v%0h.jpg" />
				<right url="kmr1_bdkmr.tiles/l2_r_%0v%0h.jpg" />
				<back  url="kmr1_bdkmr.tiles/l2_b_%0v%0h.jpg" />
				<up    url="kmr1_bdkmr.tiles/l2_u_%0v%0h.jpg" />
				<down  url="kmr1_bdkmr.tiles/l2_d_%0v%0h.jpg" />
			</level>
			<level tiledimagewidth="716" tiledimageheight="716">
				<left  url="kmr1_bdkmr.tiles/l1_l_%0v%0h.jpg" />
				<front url="kmr1_bdkmr.tiles/l1_f_%0v%0h.jpg" />
				<right url="kmr1_bdkmr.tiles/l1_r_%0v%0h.jpg" />
				<back  url="kmr1_bdkmr.tiles/l1_b_%0v%0h.jpg" />
				<up    url="kmr1_bdkmr.tiles/l1_u_%0v%0h.jpg" />
				<down  url="kmr1_bdkmr.tiles/l1_d_%0v%0h.jpg" />
			</level>
		</image>


although... in my vtour-mres.config file this is written

Source code

1
2
3
4
buildmobileimages=auto
buildmobileres=512
buildtabletimages=auto
buildtabletres=1024

HansNyb

Professional

Posts: 936

Location: Denmark

Occupation: Photographer

  • Send private message

6

Thursday, March 31st 2011, 7:45pm

Are you sure you had the license file krpanoiphone.license.js and the krpanoiphone.js in the tools folder when you run it.

Hans

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

7

Thursday, March 31st 2011, 9:36pm

aha !
As I was mixing the actual version and the beta version I forgot the krpanoiphone.license.js I think.
And yep, now I see the mobile tiles in the xml.

I'll give a try on someone's 3G first thing in the morning !

Thanks !
=servaas=

This post has been edited 1 times, last edit by "servaas" (Mar 31st 2011, 9:48pm)