Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.



  • »riefa« ist der Autor dieses Themas

Beiträge: 25

Wohnort: Jakarta, Indonesia

Beruf: VR Photographer

  • Nachricht senden


Freitag, 22. April 2011, 02:30

Navigation buttons not loading


I create a simple virtual tour with MAKE VTOUR droplet and use the default skin navigation buttons:

All seems to work well until I switch Safari's user agents to iPad / iPhone. The navigation buttons are not loading and these below are showing at the error log window:


ERROR: plugin[out] loading error: buttons.png
ERROR: plugin[up] loading error: buttons.png
ERROR: plugin[closefs] loading error: buttons.png
ERROR: plugin[dragmode] loading error: buttons.png
ERROR: plugin[left] loading error: buttons.png
ERROR: plugin[openfs] loading error: buttons.png
ERROR: plugin[right] loading error: buttons.png
ERROR: plugin[movemode] loading error: buttons.png
ERROR: plugin[down] loading error: buttons.png
ERROR: plugin[quality] loading error: buttons.png
ERROR: plugin[in] loading error: buttons.png
Any idea how to fixed this?

..or at least (for temporary solution) how to prevent the error log from automatically showing when someone access it on at least they are not aware of any errors?


P.S. i am new with this xml coding stuff, so kindly forgive me for asking some very basic questions.... *smile*
Riefa Istamar

Beiträge: 1 850

Beruf: Virtual Tours - Photography - Krpano developer

  • Nachricht senden


Freitag, 22. April 2011, 03:29

Not sure exactly whats going on but

ipad looks for

but they are here…kin/buttons.png

you could open skin/defaultskin.xml
and change the url or specifiy an alturl
to something absolute until you discover the reason why

I'm not really sure how swfpath is gotten when its html5

KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter ::



  • »riefa« ist der Autor dieses Themas

Beiträge: 25

Wohnort: Jakarta, Indonesia

Beruf: VR Photographer

  • Nachricht senden


Freitag, 22. April 2011, 10:44

Hi Sacha,

I did as you suggest to use absolute path and it works! I don't have iPad but when i simulate it with Safari, it eliminates the problem. Thanks..:)

but I still wonder why the xml do not point at the correct path when not using absolute path.

I am using PanoPress plug-in for easier handling when posting...can this be the problem?
Riefa Istamar


Freitag, 22. April 2011, 11:44


for %SWFPATH% in the krpanoJS (iPhone/iPad) viewer you would need to use at least the pre-release:

best regardsm



Beiträge: 22

Wohnort: Singapore

Beruf: Architect / Photographer

  • Nachricht senden


Donnerstag, 29. November 2012, 10:50

Skin not loading only on iOS devices but the rest no issue

Hi Klaus,

I have the same problem as reifa, on iphone/ipad I have a skin loading error but in my android phone and any computer it displays correctly. I tried changing the skin directory to absolute path by removing %SWFPATH% and it fixed it but funny thing is now I get the skin loading error in android. I changed it back so now the iphone/ipad issue remains. Except for the 1st tour in my home page is working correctly in all devices after changing to absolute path, I don't know why. All of my tours have a separate defaultskin.xml file inside the skins folder but some also have a duplicate defaultskin.xml written inside the tour.xml, I'm not sure if this is the cause but I doubt it because everything works since before.

This is my website all my tours here suddenly have the skin loading issue last month after updating my panopress plug-in for wordpress to version 1.0. I'm also contacting panopress about this.

I already have the required version of krpano installed for the %SWFPATH% to work since I created my website last May.

I hope someone helps me with this problem soon.

Thanks & regards,
James - 360º Virtual Tours & 360° Videos