You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, August 5th 2011, 2:48am

Loadpano and video not working help please

Ive got the following code im using to go from one pano to the next which contains a 360 or none 360 video i think im missing a unload event or a way to unload when i had controls on player it seemed to keep them onscreen
I would be very gratful for any help. When the intro video finishes or the first pano the 360 video doesnt spin etc just half full screen looks weird.


Flat video none pano sb2.xml

<krpano version="1.0.9" logkey="true">
<display fps="25" />

<progress showload="yes" showwait="loopings(0xFFFFFF)" />

<plugin name="video"
width="100%"height="80%"
url="videoplayer.swf"
videourl="intro.mp4"
align="center" x="0" y="0"
pausedonstart="false"
loop="false"
volume="1.0"
buffertime="0.1"
updateeveryframe="false"
onvideocomplete="loadpano(sb3.xml,null,IGNOREKEEP);"
/>


</krpano>



Sb3.xml is the 360 pano video when it loads it doesnt work any ideas

<krpano version="1.0.9" logkey="false" showerrors="true"onstart="startup();">
<display fps="15" />

<progress showload="yes" showwait="loopings(0xFFFFFF)" />

<!-- load and control the video with the videoplayer plugin -->
<plugin name="video"
url="videoplayer.swf"
videourl="5th.mp4"
deblocking="0" buffertime="5" loop="false"
onvideocomplete="plugin[video].seek(0); plugin[video].stop(); plugin[video].tooglepause(); set(plugin[play].url, play.png);"

onpause=""
maxpixelzoom="1"
keep="true"
onvideoready="do_time_bar(video,null,bottom,null,70%,6,0,5,false,10);"
updateeveryframe="true"
loop="false"
/>
<image>
<sphere url="plugin:video" />
</image>

<!-- the startup view settings -->
<view hlookat="+51" vlookat="0" fov="100" />

<!-- 3d geometry details/accuracy -->
<display details="20" />

<control usercontrol="all"
mousetype="moveto"
zoomtocursor="false"
zoomoutcursor="true"
mouseaccelerate="1.0"
mousespeed="10.0"
mousefriction="0.8"
mousefovchange=""
keybaccelerate="0.5"
keybspeed="10.0"
keybfriction="0.9"
keybfovchange="0.75"
keybinvert="false"
fovspeed="3.0"
fovfriction="0.9"
movetocursor="none"
cursorsize="10.0"
headswing="0.0"
keycodesleft="37"
keycodesright="39"
keycodesup="38"
keycodesdown="40"
keycodesin=""
keycodesout=""
touchfriction="0.87"
trackpadzoom="true"
/><!-- text styles for startup text and onhover text -->


</krpano>

This post has been edited 5 times, last edit by "misterbanner" (Aug 23rd 2011, 3:28pm)


2

Sunday, August 21st 2011, 7:29am

Just edited post.

Similar threads