You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

HansNyb

Professional

  • "HansNyb" started this thread

Posts: 1,007

Location: Denmark

Occupation: Photographer

  • Send private message

1

Friday, October 7th 2011, 5:41pm

Mac users please help

I am making a Gigapixel in 260.000x38000 and has got into the max 256 files problem

The tools does not work because to many files need to be open.

Klaus has told me I should use Terminal and run command ulimit -n 1000 ( or more)
However it does not work for me. After I have run it I just get a popup saying Apple event Handler failed when I drop the file on the droplet.
I have to close down Terminal to reset it

I searched the web and got alot of solutions. One is to make a file in the Invisible ETC folder called launchd.conf and write this in it.

limit maxfiles 1000000 unlimited

That should make the max files permanently changed . I managed to find out how to do this , however it does not work.

Anyone who knows how to do this properly.

If I run ulimit -n to find out what it says I now get this. It looks like I have 1000 but I still get errors.
Last login: Fri Oct 7 17:19:42 on ttys000
ulimit -n
ulimit -n 1000
ulimit -n 1000 ; exit;
Hans-Nybergs-iMac:~ hansiMac$ ulimit -n
256
Hans-Nybergs-iMac:~ hansiMac$ ulimit -n 1000
Hans-Nybergs-iMac:~ hansiMac$ ulimit -n 1000 ; exit;
logout

[Process completed]

Hans

2

Friday, October 7th 2011, 7:20pm

I don't know anything about Mac but have you tried using something like this in the terminal with that unlimit command? Maybe worth a shot if you have not.



Taken from the transform tool documentation

ktransform mode inputfile outputfile [rx ry rz [fov]] [options]