You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, October 12th 2011, 10:04am

onover/onhover/onout-BUG in krpano 2011-11-10

Hi Klaus,

verzeih den etwas drängelnden Beitrag, doch heute ist Abgabetermin und ich habe mit der neuen Version einen Bug in meinen Rundgängen.
Ich setze beim onover-, onhover- und onout-tag folgende Aktionen:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<plugin name="button_sitemap"
url="skin/button_sitemap.png"
origin="centerleft"
edge="center"
x="216"
y="0"
parent="interface"
keep="true"
onover="set(url,skin/button_sitemap_over.png)"
onhover="showtext(Sitemap,tooltip)"
onout="set(url,skin/button_sitemap.png)"
ondown="set(scale,0.95)"
onup="set(scale,1.0)"
onclick="if(thumbvar == 1,action(closethumbs));if(help == 1,action(closehelp));if(contact == 1,action(closecontact));if(sitemap == 0,action(showsitemap),action(closesitemap))"
/>

Mit der neuen Version (getestet mit 28-09-2011 und 11-10-2011) funktionieren die onover-, onhover- und onout-tags irgendwie fehlerhaft. Nicht immer wird beim onover der Text (showtext) angezeigt, nicht immer wird die neue url gesetzt und nicht immer wird beim onout die alte URL wiederhergestellt. Bei den vorherigen Versionen gibt es dieses Problem nicht, daher meine Vermutung das es sich um einen BUG handeln könnte?!

Ich benötige für diesen Rundgang jedoch die HTML5-Verschlüsselung, daher ist die Nutzung der alten Version (20-05-2011) kein Option.

EDIT: Wichtige Info: Der Bug muss in der neuen krpano.swf liegen, da der Fehler erst erscheint wenn ich diese austausche. Beim austauschen der krpano.js gibt es kein Problem.

EDIT2: Ich nutze vorläufig erstmal einen Mix aus 20-05-2011 (krpano.swf) und 11-10-2011 (krpano.js) womit es funktioniert. Daher hab ich das "dringend" mal entfernt ;-)

Vielen Dank und Gruß
Nupsi

This post has been edited 1 times, last edit by "Nupsi" (Oct 12th 2011, 10:18am)


2

Wednesday, October 12th 2011, 11:10am

Hi,

hast du eventuell ein Beispiel zu dem Problem?

ein mögliches Problem könnte das Ändern der URL sein - dadurch wird das ALT Bild entfernt und erst wenn das neue Bild geladen ist, das NEUE wieder angezeigt, in der Zwischenzeit kann dadurch, dass kein Bild mehr unter der Maus da ist, das "onout" Event ausgelöst werden und das "onhover" Event aufhören - das würde dann aber sowohl die alte als auch die neue Version betreffen...?!

Schöne Grüße,
Klaus

3

Wednesday, October 12th 2011, 6:09pm

Hi Klaus,

erstmal Danke für die gewohnt rasche Antwort! *thumbup*

Das von Dir beschriebene Szenario würde auch nur beim ersten laden der Ersatzgrafiken auftreten und anschließen wohl wegfallen, da diese dann ja im Speicher liegen - vermute ich zumindest. Würde aber wirklich nicht erklären warum es mit den vorherigen Versionen keine Probleme diesbezüglich gab.

Heute bin ich leider zu knapp an Zeit, aber ich versuche Dir morgen jeweils mal ein Beispiel mit den beiden Versionen online zu stellen.

Dank und Gruß
Nupsi