You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

3sfera

Intermediate

  • "3sfera" started this thread

Posts: 224

Location: Mexico City

Occupation: Virtual tours, Krpano coding, Graphic Design, Photographer, Panographer

  • Send private message

1

Friday, October 21st 2011, 10:37pm

Trying to define an extra parameter for <autorotate>

Hello everyone, I'm trying to define an extra parameter for <autorotate>. As documentation states, the parameters for <autorotate> are:

Source code

1
2
3
4
5
6
7
8
<autorotate 
            enabled=""
            waittime=""
            accel=""
            speed=""
            horizon=""
            tofov=""
            />


I'd like to define the extra parameter speed_backup="(SOME VALUE)" at the end of the code, just bellow tofov="". I've seen in some examples of Krpano Viewer that extra parameters can be created for hotspots, just by defining them (parameter="(SOME VALUE)") at the end of all the other parameters. In my case I'd already tried coding an extra parameter by this way but it has worked for me just for plugins/hotspots, in the case of autorotate it is not being recognized. Do anyone know if this extra parameter can be defined? or in which tags extra parameters can be defined? As I mentioned, I have extra parameters running for hotspots & plugins but they won't work for <autorotate> tag. Thank ya pals!!

Cheers. *smile*

Luis Erantzcani

2

Thursday, October 27th 2011, 12:28pm

Hi,

some elements in krpano are dynamic and some not,
dynamic means adding custom attributes is possible,

basically only the plugin, hotspot, events and all custom elements are dynamic, but the most other native elements are NOT dynamic, e.g. these ones: area, autorotate, control, cursors, display, image, lensflare, network, progress, textstyle, view - adding custom attributes - adding there attributes is not possible,

best regards,
Klaus

3sfera

Intermediate

  • "3sfera" started this thread

Posts: 224

Location: Mexico City

Occupation: Virtual tours, Krpano coding, Graphic Design, Photographer, Panographer

  • Send private message

3

Friday, October 28th 2011, 9:05pm

Okey Klaus, I see now why it wasn't working. Thanx a lot for your help!

By the way, you impress me man, how do you do to answer to that much of posts here in the forum?? I'm beggining to guess there are more than one people behind Klaus, hehe, but that's just a guess... *tongue*

Best Regards.

Luis