You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, January 14th 2012, 9:57am

Initial zoom setting

Hi,

Where is the initial zoom setting for the viewer? I would like to back it off a little so the space seems a little larger on a big screen.

2

Tuesday, January 17th 2012, 1:42pm

you define it with the fov parameter inside the view node, see Docu http://krpano.com/docu/xml/#view.fov

3

Thursday, February 2nd 2012, 6:27pm

Which file to edit?

*huh* I don't know where the "view" node is. I'm only making multires tours and I can see HFOV in kmakemultires.conf and vtour-mres.config. Do I add the FOV parameter to one/both of these? If not, where can I find the view node?

4

Thursday, February 2nd 2012, 7:21pm

Hi,

either edit the generated xml files or the template xml,

e.g. see the "templates\xml\default.xml" file when using the MAKE PANO (MULTIRES) droplet,

best regards,
Klaus

5

Tuesday, February 14th 2012, 5:33am

Your documentation is extremely good but I cannot make the initial zoom setting change regardless of the settings I try in fov. Would you mind editing this string to zoom out and note which element you changed? I am pasting this into default.xml as instructed before.

<view hlookat="0.0"
vlookat="0.0"
camroll="0.0"
fovtype="VFOV"
fov="90.0"
fovmin="1.0"
fovmax="179.0"
maxpixelzoom=""
fisheye="0.0"
fisheyefovlink="0.5"
limitfov="true"
stereographic="false"
pannini="false"
architectural="0.0"
architecturalonlymiddle="false"
limitview="auto"
hlookatmin=""
hlookatmax=""
vlookatmin=""
vlookatmax=""
/>

6

Tuesday, February 14th 2012, 5:49am

If you want to zoom out, edit the fov="90"

Change it to a bigger number. If making this change does not help, maybe you need to show your xml as something is probably setting fov somewhere else in the code. Perhaps in the scene tag, if you use scenes.

7

Tuesday, February 14th 2012, 7:16pm

vtour_viewtemplate.xml

Hi,

Editing this file, instead of default.xml, produced a change to the initial zoom.

Thanks for your replies to all my emails.

Aaron

JPS

Beginner

Posts: 10

Location: Geneva, Switzerland

  • Send private message

8

Sunday, March 4th 2018, 3:42pm

Hi !

Sorry to have to revive this old thread, but I tried to change the "fov=90" to "fov=120", and nothing happened, I tried to put a higher figure, like 170, but... still no change !

Also, where do I find the "fovmin" and "fovmax" data ?

What have I done wrong ? BTW, my Krpano version is the 1.19 !

Thanks in advance for any help...
JPS has attached the following image:
  • Untitled-1.jpg

This post has been edited 2 times, last edit by "JPS" (Mar 4th 2018, 3:53pm)


jeromebg

Professional

Posts: 792

Location: Angers - France

Occupation: Photographer

  • Send private message

9

Sunday, March 4th 2018, 9:05pm

Hi !

Sorry to have to revive this old thread, but I tried to change the "fov=90" to "fov=120", and nothing happened, I tried to put a higher figure, like 170, but... still no change !

Also, where do I find the "fovmin" and "fovmax" data ?

What have I done wrong ? BTW, my Krpano version is the 1.19 !

Thanks in advance for any help...

If your scene fovmax setting is lower than 170 then autorotate won't go to 170.
Check your scenes view settings (eg <view hlookat="0.0" vlookat="0.0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />)

JPS

Beginner

Posts: 10

Location: Geneva, Switzerland

  • Send private message

10

Sunday, March 4th 2018, 11:30pm

Hi ! Thanks for the response, but I'm afraid you didn't understand ! I don't care about "autorotate" (in fact, I'd prefer not to have it ON) !

What I want is to make the START field_of_view (when I click on the "index.html" file) WIDER, and allow to ZOOM IN a bit deeper, and ZOOM OUT a bit less than the originals !

What data should I change, and WHERE, in "xxx/skin/" file or in an other file !

...and best, I'd like to change these data in the ORIGINAL file, (in KRPANO directory), that builds the directory usable to run each panorama...

*smile*

This post has been edited 1 times, last edit by "JPS" (Mar 5th 2018, 9:18pm)


JPS

Beginner

Posts: 10

Location: Geneva, Switzerland

  • Send private message

11

Friday, March 9th 2018, 1:11pm

Up !

12

Tuesday, March 13th 2018, 10:24am

Hi,

look in the startup xml file (e.g. the tour.xml or pano.xml depending on what droplet you have used) for a <view> element and there change the 'fov' setting!

After changing clear the browser change to make sure to see the updated file.


Quoted

...and best, I'd like to change these data in the ORIGINAL file, (in KRPANO directory), that builds the directory usable to run each panorama...
For tours build using the MAKE VTOUR droplets edit the fov setting in this file:

Source code

1
templates/xml/vtour_viewtemplate.xml

and for panos build using the MAKE PANO droplets add a fov setting in this file:

Source code

1
templates/xml/default.xml


Best regards,
Klaus

JPS

Beginner

Posts: 10

Location: Geneva, Switzerland

  • Send private message

13

Tuesday, March 13th 2018, 11:36am

Hi Klaus !

Thanks for the tips ! I'm not home these days, but as soon as I go back, I'll try that !

Best regards,
J-P.