You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, January 24th 2012, 7:58pm

Problem with picture hotspot in on iPad - difference vs.

Hi, i came back to krpano after nearly year of brake to create new virtual tour, and i just finished it. FInal destination of this tour is iPad app. It's working quite nicely, except one thing:

i'm using picture hotspots for loading and showing of images (for each piece in gallery there is card with info about this particular art). When i did this last year with, it was working like charm - you clicked on "magnifying glass with + sign" and card with info showed. With current version it's working same way, with one major glitch - magnifying glass will not disappear and is still present on screen, how you can see on attached picture. This error appears just on iPad, so i didn't found it until now :(.

I tested old tour created last year and it's still working without problem. I checked XML definition for hotspot, but it's basically just copied from last years project. So then i tried to copy new version of Krpano to old project and now it behaves exactly same like new project - hotspot will not disappear as expected.

From this i can came just with one conclusion - something is different in .14 version, and without help i have no chance to get rid of this problem.

You can simulate this problem with Safari on desktop, when you choose iPad as User Agent in Develop menu.

Thanks for fast help!
maler has attached the following images:
  • krpanoscreen2.jpg
  • krpanoscreen1.jpg

Posts: 1,851

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message


Tuesday, January 24th 2012, 9:59pm

Looks like distorted hotspots don't support zorder. They are always lowest on the totem pole.
If I disable distorted, it works fine.

SOOooo... temporarily hide your magnifying glasses so it doesn't look ugly. That should solve it.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter ::


Wednesday, January 25th 2012, 6:56pm


this is technically limitations (bug) of the current Safari browsers regarding to the distorted hotspots (in version there were no distorted hotspots, so the problem doesn't occur there),

when the distorted hotspots were placed over the normal hotspot elements, then the Javascript events were not working correctly anymore, so it was neccesery to put them behind the normal hotspots,

but I working already on solution by avoiding the buggy browser events and doing the click detection by my own, then I can re-order the hotspots correctly,

a temporary solution would be like Sacha already recommended hiding the magnifying glasses as long as the hotspots is visible, and then showing it again on hotspot minimizing,
or just disable the distorted hotspots (then it will be like in version,

best regards,


Thursday, January 26th 2012, 10:43am


would by any of you so kind and can you let me know how to do either of these two things?


Thursday, January 26th 2012, 12:58pm

I've found another issue - i use animated hotspots for walking between scenes. When such hotspot is covered by picture opened by pic-hotspot, i can't close this picture by taping on it. I must move with panorama so animated hotspot is out of the picture, then i can close it.

So if i can somehow "restore" behavior of hotspots from .12, it will be best way for me.



Edit: seems that this is not replicable...

2nd edit - so, it appears quite often during testing, but not every time... great for bugfixing.

This post has been edited 2 times, last edit by "maler" (Jan 26th 2012, 3:05pm)