You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

fredp

Beginner

Posts: 21

Location: Brisbane, Australia

Occupation: Software Engineer

  • Send private message

21

Thursday, July 4th 2013, 5:09am

Sorry for the delay, I have not seen your replies until now.

misterbanner:
  • You should have no issues playing flv files (you don;t even need to specify the .flv extension in the URL). Can you play from a local directory into the pano layer?
  • I forget what the sample video on serverroom is called, but all you need to do is contact serverroom support. They are very helpful.

otdeta:
  • SDP files work fine - we have used them extensively. Error #2123 is a failed attempt to access the video samples, and indicates that the application XML is not configured to allow video sample access (see my earlier post on this matter above).

22

Friday, July 12th 2013, 10:53am

Hi, fred!
Thanks for answer.

Currently set up by CDN, the error was gone, but the picture is not transmitted through KrPano.

I do not understand where the error occurred.

Broadcast to the standart player goes well.

http://ria360.ru/video3.html

Player connects to the stream but the images are not visible.
INFO: krpano 1.0.8.15 (build 2012-10-05)
INFO: Flashplayer WIN 11.7.700.224 PlugIn
INFO: registered to: Pavel Khalzov
INFO: rtmp server = rtmp://fedya.cdnvideo.ru/fedya-live/
INFO: rtmp stream =fedya.sdp
INFO: Connected successfully to server
otdeda has attached the following image:
  • broadkast.png

23

Tuesday, July 30th 2013, 9:57am

it s working, but not fine

hello,


i tried out the modified player and found a helpfull streaming service ( video-stream-hosting.de), which was very interested to make it possible to stream 360 videos, the founder contacted klaus

and after this it was working the first time.

the only problem is now that its working very bad as you can see.

http://ilupan.de/360bikealster/index.html

the filesize of this example is 1,5 gig but also with small files i got the same problems

does anybody know what i can do ? it would be great if it would work with streamed videos.

nice day stefan

fredp

Beginner

Posts: 21

Location: Brisbane, Australia

Occupation: Software Engineer

  • Send private message

24

Wednesday, July 31st 2013, 1:19am

Hi Stefan,

On the first play through I had no issues on Chrome for Mac - it played smoothly, but then on subsequent plays (and on various browsers) the video is intermittently very choppy. I think this points to a bandwidth issue from the hosting site. Do they provide any guarantees about bandwidth? Do they have any policies that might affect connection speed after a certain amount of data is streamed?

Fred.

25

Thursday, October 24th 2013, 3:56pm

last slash

Good day,
I did some tests with rtmp stream

server:
rtmp://moze.cdnvideo.ru/mc10/_definst_/
stream:
mp4:10:/video360/web.mp4
videourl:
rtmp://moze.cdnvideo.ru/mc10/_definst_/mp4:10:/video360/web.mp4
TRACE:
INFO: rtmp server = rtmp://moze.cdnvideo.ru/mc10/_definst_/mp4:10:/video360/
INFO: rtmp stream =web.mp4 BUT STREAM IS mp4:10:/video360/web.mp4
INFO: Connected successfully to server
Video does not play


server:
rtmp://176.31.227.113/matele/_definst_/
stream:
mp4:jite-2013-06-25-1500.m4v
videourl:
rtmp://176.31.227.113/matele/_definst_/mp4:jite-2013-06-25-1500.m4v
TRACE:
INFO: rtmp server = rtmp://176.31.227.113/matele/_definst_/
INFO: rtmp stream =mp4:jite-2013-06-25-1500.m4v
INFO: Connected successfully to server
Video is played

Klaus

please add same rtmp Attributes for Videoplayer Plugin like:
server=""
stream=""


server wowza

26

Sunday, January 18th 2015, 3:45am

I've had great success with playing back mp4 h.264, webm and ogv files on flash/html5.

But, when i send an rtmp feed, i hear audio but no video on the Flash player.
I see the following error in the player output/console: SecurityError: Error 2123
Clicking play shows NaN but does change the state to video is playing.

Interestingly, http://jwplayer.com/wizard/ plays the video when the same rtmp url is used so it seems like the rtmp feed might be ok.


Tested with both Adobe Flash Media Server and Wowza Streaming Engine running locally. KRPano is served by apache httpd locally as well, so the IP address is the same, but different ports.

Crossdomain.xml is setup at http://IPADDRESS:1935/crossdomain.xml and http://IPADDRESS/crossdomain.xml

<cross-domain-policy>

<allow-access-from domain="*" secure="false"/>
<site-control permitted-cross-domain-policies="all"/></cross-domain-policy>
videourl=rtmp://IPADDRESS:1935/live/myStream


Based on the 2012 updates by fredp

I made the changes to output raw video as recommended - to the Application.xml for Wowza. But no improvement after restarting.


When updated with the videoplayer.swf attached to the above thread, i do not get security errors. But - the play button does not play video at all (no audio either) and no update to start/end time, the output shows
INFO rtmp server = rtmp://IPADDRESS:1935/live/
INFO rtmp stream =mystream
INFO COnnected successfully to server


is the videoplayer that was attached still applicable to the current 1.18.1 krpano? Not sure if its outdated since it was attached to the thread in 2012. I dont see the rtmp INFO output when using 1.18.1 krpano




video.xml is

Source code

1
<krpano version="1.18" bgcolor="0x000000" debugmode="false" logkey="true" showerrors="true">        <!-- the videoplayer interface skin -->    <include url="../skin/videointerface.xml" />        <!-- include the videoplayer plugin and load the video (use a low res video for iOS) -->    <plugin name="video"    url.flash="%SWFPATH%/plugins/videoplayer.swf"    url.html5="%SWFPATH%/plugins/videoplayer.js"        pausedonstart="true"    loop="false"    enabled="false"    zorder="0"    align="center" ox="0" oy="0"        width.no-panovideosupport="100%"    height.no-panovideosupport="prop"        onloaded="videointerface_setup_interface(get(name));"    onvideoready="videointerface_videoready();"    onvideocomplete="videointerface_videocomplete();"    />    <!-- see skin xml -->        <!-- the panoramic video image -->    <image devices="panovideosupport">        <sphere url="plugin:video" />    </image>            <!-- set the default view - a light fisheye projection -->    <view hlookat="0" vlookat="0" fovtype="DFOV" fov="130" fovmin="75" fovmax="150" fisheye="0.35" />    </krpano>




Please help! Thanks in advance!

27

Monday, January 19th 2015, 10:14am

Hi,

the rtmp support should work, but use the up-to-date krpano.swf and videoplayers.swf from the krpano version itself, any attached files in this thread might be outdated.

Best regards,
Klaus

28

Monday, January 19th 2015, 10:42pm

Thanks, i'll double check all my settings and files to make sure nothing got messed up when trying different permutations.

Thanks!

29

Monday, February 2nd 2015, 8:02pm

We resolved the issue. We found Akamai had a bug in its console where it wasn't propagating all of the settings to the server. Once we worked with Akamai support and our sample access was updated correctly, everything worked. Thanks!!!!!

It would be good to add the notes on sample access to the video plugin documentation instead of new users having to look at the forum. just a suggestion.

30

Tuesday, February 3rd 2015, 10:29am

It would be good to add the notes on sample access to the video plugin documentation instead of new users having to look at the forum. just a suggestion.
Okay, but what notes do you mean?

Best regards,
Klaus

31

Thursday, March 5th 2015, 10:57am

Hi,

I'm interest by the 360Video Streaming.

Is there a way to see a live demo ?

Thanks for your feedback. *smile*

32

Tuesday, January 19th 2016, 2:35pm

Is it possible to do RTSP streaming? Bascially I want to do Live streaming in Android browsers. RTMP I guess is not supported there and neither is HLS. The only option is RTSP. (hope I'm right about this).

Any ideas? Thanks!!