You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

41

Monday, September 1st 2014, 12:19pm

Hi,

please wait for version 1.18 ;-)

There will be a full and easy reusable example for exactly this case.

Best regards,
Klaus

42

Monday, November 27th 2017, 12:43pm

I have the same problem. The second time the layer is not shown.
onclick="addlayer(youtubeiframe);" does not reopen... my version 1.19.13

43

Tuesday, November 28th 2017, 8:23pm

Hi,

just a 'addlayer' call would only add an empty <layer> element, but nothing else.

Please see this example (included in the download package) for a Youtube example:
https://krpano.com/examples/usage/#inline-video-players

Best regards,
Klaus

44

Monday, December 4th 2017, 10:46am

button overlay over video layer

a bit off topic on this, but related since i am using this XML example for a video.


All is working fine.
But now i want to add a 'button' layer to skip the video and trigger some action.


I see the button layer, the mouse hovers over it, but the onclick event is not triggered.
Only when the video-layer is closed, the onclick event of the buttons is actually triggered.


It feels like something is blocking it, while the video is playing.
Is this right? can i do something about this?


as a quick test i added this layer:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
 <layer name="FF"
        type="container"
       zorder="9999999"
       align="center"
       width="50"
       height="50"
       bgcolor="0x000000"
       bgalpha="1"
       keep="true"
       alpha="1"
       bgcapture="true"
       onclick="showlog();trace(hi);"
/>



so the onclick is not triggerd when the video layer is there and playing,
but when the video layer is deleted, it does trigger.


I want to create a basic button to 'skip this video' and move on to the next step...


Any ideas?


herrpedro

Trainee

Posts: 136

Location: Lisbon

Occupation: Programmer/analyst

  • Send private message

45

Friday, September 21st 2018, 4:08pm

hi,

just added youtube to a tour. thanks.

can this be done in vr mode?
or must i "remove" the youtube button on entering vr?

thank you for your help

46

Monday, September 24th 2018, 6:00pm

Hi,

the WebVR Browser API allows only using manually rendered WebGL content in VR - that's excludes all HTML elements.

And the only API that Youtube offers for embedding is via <iframe> and that's a HTML element.

That means Youtube is not possible in VR.

Best regards,
Klaus