You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

bg360

Trainee

  • "bg360" started this thread

Posts: 93

Location: Bulgaria

  • Send private message

1

Saturday, May 12th 2012, 1:51pm

sound doesn't work

Hello,

I can't run sound on Safari browser with iPad and iPhone user agent.

http://portreti.bg360.net/johnny-penkov.php
http://portreti.bg360.net/johnny-penkov/view.xml

Regards,
Mitko

2

Saturday, May 12th 2012, 8:01pm

Hi,

Seems path of sound.mp3 is wrong,
Check the file location and the path to this file in your .xml

Z

bg360

Trainee

  • "bg360" started this thread

Posts: 93

Location: Bulgaria

  • Send private message

3

Saturday, May 12th 2012, 8:04pm

Hi,

Seems path of sound.mp3 is wrong,
Check the file location and the path to this file in your .xml

Z
Hi,
but it works on PC... So, the file is in the right place.

4

Monday, May 14th 2012, 11:51am

Hi,

the rootpath setting isn't currently supported in the html5 version and that seems the reason for the wrong path in the html5 (iphone/ipad) case,

you could either use the %CURRENTXML% placeholder diretcly in the playsound call,
e.g.

Source code

1
playsound(sound, %CURRENTXML%/sound.mp3, 0);


or try the new 1.0.8.15 pre-release - there the rootpath should work:
http://krpano.com/download/beta/#2012-05-04

best regards,
Klaus