You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

MarcoW

Beginner

  • "MarcoW" started this thread

Posts: 11

Location: Bali, Indonesia

  • Send private message

1

Saturday, May 19th 2012, 1:21pm

Full Screen Overlay Plugin Mask Effect Not working on iphone/ipad

Hello,
My recent mini-tour works fine in flash with the overlay full screen plugin overlay Dark Shadow mask effect;
CharMing Restaurant Bali Virtual Tour

However when displaying it on iphone/ipad, the overlay image loads but covers everything and doesn't blend the white/grey area..
Isn't it possible to use this feature on iphone/ipad, or do I have to edit the code in a certain way?

Source code

1
<plugin url="charmingdata/graphics/darkmask.jpg" name="mask" blendmode="multiply" origin="lefttop" width="100%" height="100%" enabled="false" zorder="-1" keep="true" />


Sorry if this has been asked before on the forums and thank in advance for any help!

This post has been edited 3 times, last edit by "VVBali" (Jan 1st 2013, 6:23am)


Tuur

Sage

Posts: 3,120

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Saturday, May 19th 2012, 1:44pm

did you try other blend modes?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

MarcoW

Beginner

  • "MarcoW" started this thread

Posts: 11

Location: Bali, Indonesia

  • Send private message

3

Saturday, May 19th 2012, 2:37pm

Thanks Tuur,

Didn't try that yet before you asked, but now also tried with blendmode="screen" and blendmode="difference" with same result on iphone/ipad as with blendmode="multiply"..

4

Saturday, May 19th 2012, 2:40pm

hi Marco...look at

http://krpano.com/iphone/

unsupported xml tags/ variables

plugin/hotspot[].mask

imge

Tuur

Sage

Posts: 3,120

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

5

Saturday, May 19th 2012, 3:01pm

well that list is not 100% true i think..

But i'm afraid IMGE is right here. try a png with alpha channel.
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

MarcoW

Beginner

  • "MarcoW" started this thread

Posts: 11

Location: Bali, Indonesia

  • Send private message

6

Sunday, May 20th 2012, 3:55am

Obviously Blendmode is not supported on iDevices as IMGE mentions, thanks for pointing that out.

Using a png with transparency seems to do the trick (with or without Alpha Channel), Thanks Tuur for the suggestion!
When testing on computer with Safari 5.1 under "User Agent/iPhone or iPad", my mouse-pointer disappears behind the overlayed image plugin. Don't know yet if it is still possible to click the hotspot to the other pano on iDevices like this, have to check with a real iPhone/iPad and will report later.

MarcoW

Beginner

  • "MarcoW" started this thread

Posts: 11

Location: Bali, Indonesia

  • Send private message

7

Saturday, May 26th 2012, 7:34am

Tried the pano's and on OSX (Safari 5.1 and Chrome) and works fine on my MacbookPro, but..

Testing on iPhone and iPad, the panorama load and is visible through the mask, but the hotspot is not clickable.
Same problem occurs on OSX (10.7) Safari/Development/User Agent/IOS, her the mouse pointer disappears behind the mask and hotspot is not clickable as well.. Played with the zonder (positive values) of mask and hotspot, but I seem unable to get it to work!?

Would it be possible to disable the mask for iDevices only??

Hope somebody can have a look (link in my first post in this thread) and has some more ideas.

Marco

MarcoW

Beginner

  • "MarcoW" started this thread

Posts: 11

Location: Bali, Indonesia

  • Send private message

8

Saturday, May 26th 2012, 7:55am

After applying krpano 1.0.8.15 Prerelease - krpanoiphone.js it seems to work fine now. Still have to test on friends iPhone and iPad but in Safari 5.1 OSX it works now, so I am pretty convinced it will work on actual iDevices :)

Thanks for your attention and sorry to bother ya'll.

Marco