You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

1

Tuesday, June 26th 2012, 8:40am

iphone/ipad sound -> HTML5 audio is not supported, HELP needed

Hi.
I've just finished a tour for iphone/ipad, but when i try to open it in safari - i get a warning message

Quoted

WARNING: soundinterface - HTML5 audio is not supported by this browser!
It works in usual mode in this browser, but when switching to iphone - i get message and sound doesn't work.

Does it mean, that it does not work only in Safari, but it will be working on iphone?? I dont have an iphone, so i cant check it by myself.
the code is^

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
<krpano version="1.0.8.14" onstart="startup();playMusic()">
	<!-- vtour.xml template krpano tools version 1.0.8.14 -->
		<action name="startup">
		<!-- load the first scene -->
		loadscene(get(scene[0].name), null, MERGE);
		<!-- build thumbnails when there is more than one scene (remove the line below to remove the thumbnails) -->
		if(scene.count GT 1, buildthumbs(); );
	</action>
	<!-- disable the default progress bar -->
	<progress showload="none" showwait="none" />
	<!-- hotspot styles (for Flash and HTML5) -->
	<style name="hotspot_ani_white"
	   	url="hotspots/hotspot_ani_white_64x64x20.png"
	   	crop="0|0|64|64"
	   	framewidth="64" frameheight="64" frame="0" lastframe="19"
	   	onloaded="hotspot_animate();"
	   	altonloaded="if(isphone, mul(scale,2)); onloaded();"
	   	/>
	<action name="hotspot_animate">
		inc(frame,1,get(lastframe),0);
		mul(ypos,frame,frameheight);
		txtadd(crop,'0|',get(ypos),'|',get(framewidth),'|',get(frameheight));
		delayedcall(0.03, if(loaded, hotspot_animate() ) );
	</action>
       <plugin name="soundinterface"
    	url="plugins/soundinterface.swf"
    	alturl="plugins/soundinterface.js"
    	keep="true"
    	preload="true"
    	/>
<action name="playMusic">
     	playsound('Music', 'buttons.mp3', loops='1')
   	</action>

	<scene................> 
arhivarius.org

2

Tuesday, June 26th 2012, 9:12am

Hi,

what Safari version are you using?

Regarding to:
http://caniuse.com/#feat=audio

HTML5-Audio should be available since iOS 4.0 and Safari 5.0.

Best regards,
Klaus

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

3

Tuesday, June 26th 2012, 9:13am

Oh, i've just try to open a file in http://www.testiphone.com/ and it works!
so the answer to my question is yes *tongue*
arhivarius.org

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

4

Tuesday, June 26th 2012, 9:15am

Hi,

what Safari version are you using?

Regarding to:
http://caniuse.com/#feat=audio

HTML5-Audio should be available since iOS 4.0 and Safari 5.0.

Best regards,
Klaus
Its strange, but
INFO: krpano JS 1.0.8.14 (build 2012-03-16)
INFO: Desktop/Win32 - Safari:5.0.2
arhivarius.org

5

Tuesday, June 26th 2012, 9:28am

Hi,
Oh, i've just try to open a file in http://www.testiphone.com/ and it works!
Forget that page! That's just a stupid iframe with an iPhone layout around .

What Windows version (2000, XP, 7) are you using?
And are the Soundcard drivers correctly installed?

Best regards,
Klaus

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

6

Tuesday, June 26th 2012, 9:37am

I get that warning messages on 2 computers: one with Win7 at my notebook and WinXP on this PC, sound drivers is ok on both, i dont have a problems with it, + lastest browser. *confused*
arhivarius.org

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

7

Tuesday, June 26th 2012, 9:46am

link to tour - http://arhivarius.org/iphone1/mobile1.html

I test it on iPhone - it works, but i dont understand why the lastest browser do not support html5 audio..
arhivarius.org

This post has been edited 1 times, last edit by "lilxxl" (Jun 26th 2012, 12:45pm)


Tuur

Sage

Posts: 3,225

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

8

Tuesday, June 26th 2012, 2:04pm

did you try just

playsound(Music, buttons.mp3, 1);

without the single apostrophe's??

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

lilxxl

Beginner

  • "lilxxl" started this thread

Posts: 9

Location: by, minsk

  • Send private message

9

Tuesday, June 26th 2012, 2:24pm

did you try just

playsound(Music, buttons.mp3, 1);

without the single apostrophe's??

Tuur *thumbsup*
Yes, i did. The same result.
arhivarius.org

10

Monday, July 9th 2012, 12:09pm

Hi,
but i dont understand why the lastest browser do not support html5 audio..
this is definitely not a normal case, but the problem itself must be system/browser related...
typically it should work fine in the current browsers...

best regards,
Klaus

11

Friday, August 31st 2012, 11:39pm

Hi I have the same problem!! *confused*

12

Tuesday, September 4th 2012, 10:25am

Hi,

sorry, I have no idea why Safari doesn't support the html5 <audio> element on some systems...

maybe try that page (with the same user agent like when testing krpano):
http://html5test.com/#table-audio

what does it tell in your case about the audio element?

best regards,
Klaus

13

Tuesday, September 4th 2012, 11:12am

maybe try that page (with the same user agent like when testing krpano):
http://html5test.com/#table-audio


Hi, thanks for your reply! I have 0 score with audio and video elements when testing my safari browser with the mentioned page! Safari version 5.1 *huh*

14

Tuesday, September 4th 2012, 11:25am

Hi,

I have googled once more about that issue and found these page:
http://happyworm.com/blog/2010/08/17/saf…l5-based-media/
https://discussions.apple.com/thread/254…tart=0&tstart=0

it seems the Windows Safari browser needs Quicktime to be installed to be able to play HTML5 Audio and Video...

so - do you have Quicktime installed?

if not, you can download it here:
http://www.apple.com/quicktime/download/

(btw - just a note - the latest krpano HTML5 viewer works also in other HTML5 browsers like Chrome or Firefox)

best regards,
Klaus

15

Tuesday, September 4th 2012, 1:44pm

Hi, yes I have quicktime installed! *huh* May be the problem have something with the system language!

16

Saturday, February 2nd 2013, 3:00pm

Hi, i have try your vtour with my chrome on win7 and i receive this error:


INFO: krpano 1.0.8.14 (build 2012-03-16)
INFO: Flashplayer WIN 11.5.31.138 PlugIn
INFO: registered to: Егор Наркевич
ERROR: decoding failed - plugins/soundinterface.js

may be that the problem is this?

17

Tuesday, February 5th 2013, 5:21pm

Hi,

INFO: krpano 1.0.8.14 (build 2012-03-16)
INFO: Flashplayer WIN 11.5.31.138 PlugIn
INFO: registered to: Егор Наркевич
ERROR: decoding failed - plugins/soundinterface.js

Note - the Flashplayer can't load/use HTML5 (.js) plugins!

Best regards,
Klaus

18

Wednesday, May 15th 2013, 8:11pm

I have the same problem , please.

ERROR: soundinterface - loading of som.mp3 failed

with my older tour, I did not have this problem.

Thank you

This post has been edited 1 times, last edit by "Net360" (May 15th 2013, 8:38pm)


19

Wednesday, May 15th 2013, 8:54pm

I have the same problem , please.

ERROR: soundinterface - loading of som.mp3 failed

with my older tour, I did not have this problem.

Thank you



I fixed the problem already Thank you..