You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, September 4th 2012, 1:46pm

Tour editor generates strange chars before hotspots

Hi Klaus,

after generating some tours I was annoyed of the formatting of the generated hotspots,
because they look like this after generation:

Source code

1
2
3
		<!-- place your scene hotspots here -->
		<hotspot name="spot1" style="skin_hotspotstyle" ath="-59.567" atv="19.139" linkedscene="scene_haus_1_anbau" />
		<hotspot name="spot2" style="skin_hotspotstyle" ath="-91.396" atv="13.955" linkedscene="scene_haus_1_garten" />


Much more usable and clearer is a fomat like this:

Source code

1
2
3
4
5
6
7
8
9
10
11
    	<!-- place your scene hotspots here -->
    	<hotspot name="spot1" 
    		style="skin_hotspotstyle" 
    		ath="-59.567" 
    		atv="19.139" 
    		linkedscene="scene_haus_1_anbau" />
    	<hotspot name="spot2" 
    		style="skin_hotspotstyle" 
    		ath="-91.396" 
    		atv="13.955" 
    		linkedscene="scene_haus_1_garten" />


To edit this manually is a lot of needless work.

OK, I'm working with my favourite tool BBEdit and a search-and-replace shoukd be one of my
easiest practices. That was my first thought ... ;-)

I copied the part between the hotspots to replace it with /r/t (new line and then one tab)
but - NO occurrence is found. Huh?

I looked at the invisible chars and see flipped question marks. Here is a screenshot:



Between the hotspots is this obscure flipped question mark with two tabs followed.

Where is that generated and where can I setup another formatting of the generated hotspots?
I don't want to have more work than needed ;-)

Thanks a lot in advance and regards,

Josch

2

Sunday, September 9th 2012, 12:42pm

Hi,

the tools are currently using the the wrong encoding on Windows on Mac,
that means on Mac you will currently get Windows text files,

typical Windows text files are using two characters for a linebreak (CRLF),
were typical Mac text files are using only one (LF),

your editor seems to detect that right (see the note about Windows CRLF at the status bar), but it seems not to be able to handle them correctly,

maybe look if your editor has an 'conversion option' for converting Windows to Mac files...

btw - the next krpano release, will build typical Mac text files on Mac and typical Windows text files on Windows,

best regard,
Klaus