You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, June 3rd 2009, 5:35pm

Show Progress bar only at beginning

Hi,
in a multires pano I often see the progress bar for loading the images. I know I can deactivate this with:

Quoted

<progress showload="none"
showwait="none" />
But the problem is that I also have NO progress bar at beginning. Is it possible, that when I first open the pano, I see the progress bar, but when the player loads the next level of multires tiles I don´t see this bar?

Regards,
Maw

2

Wednesday, June 3rd 2009, 6:01pm

Hallo Marc,
hast Du schon probiert, "showload" mit dem "set..."-Befehl umzudefinieren? Zeitpunkt: dazu würde sich das "onloadcomplete"-event der ersten scene anbieten, das feuert bei multires nämlich nicht erst, wenn die ganzen bilddaten des panos geladen sind, sondern...

- onloadcomplete
- called when the loading of the pano is finished
- note for multiresolution panorams this is only called once
when the first view loading is finished
Ich weis nicht, ob das geht, aber in der doku steht nicht, dass diese progress-parameter nur initial eingelesen werden...

Alternativ:
Ich verwende grundsätzlich eine sehr kleine, unauffällig platzierte showwait-variante, weil ich mich weiter dann nicht mehr darum kümmer möchte:

Source code

1
<progress showload="bar(lefttop,8%,6,3,3,solid, 0x000000,0xFFCC00,0xFFCC00)" showwait="none" />

allerdings sollte dort während Ladeaktivitäten noch ein Miniminikommentar hin (zB.: "loading")

Grüße,
Oliver
best regards from www.PanAustria.com

3

Friday, June 5th 2009, 1:17pm

Hallo Oliver,
auch wenn ich nicht soo der Programmierer bin, aber deine Theorie klingt einleuchtend, werde ich wohl heute Nachmittag versuchen ;-)
Danke dir!

Gruß Marc

4

Friday, June 5th 2009, 11:01pm

Hallo Oliver,
ich bin es wieder ;-)

Ich habe es nun versucht, also die Ladebalken sind zuerst aktiviert und dann mit onloadcomplete wird die Action ausgeführt, die die Ladebalken ausschaltet.
Leider klappt es bisher nicht. Entweder habe ich einen Fehler drinnen, oder man kann "progress" nicht mit set() ansprechen...

Quoted

<krpano onloadcomplete="hideprogressbar">

<progress showload="bar()"
showwait="loopings()"
/>

<action name="hideprogressbar">
set(progress.showwait,none);
set(progress.showload,none);
</action>
Gruß Marc

5

Friday, June 5th 2009, 11:34pm

Ich weis nicht, ob das geht, aber in der doku steht nicht, dass diese progress-parameter nur initial eingelesen werden...
mittlerweile können die <progress> Einstellungen auch dynamisch geändert werden



Quoted

Leider klappt es bisher nicht. Entweder habe ich einen Fehler drinnen, oder man kann "progress" nicht mit set() ansprechen...
da ist noch ein kleiner Fehler drin
das "onloadcomplete" Event wird in <events> definiert,
so sollte es funktionieren:

Source code

1
2
3
4
5
6
7
8
9
10
11
<events onloadcomplete="hideprogressbar();" 
        />
 
<progress showload="bar()"
          showwait="loopings()"
           />
 
<action name="hideprogressbar">
    set(progress.showwait,none);
    set(progress.showload,none);
</action>


Schöne Grüße,
Klaus

6

Friday, June 5th 2009, 11:57pm

perfekt - danke euch Beiden!
Funktioniert genauso wie ich es mir vorgestellt habe ;-)

Schöne Grüße,
Marc

7

Saturday, June 6th 2009, 12:15am

Freut mich für Dich!

Arbeitest Du schon mit der neuen release, wenn ja, würde mich (vielleicht auch Klaus) interessieren, ob sich bei deinen HiRes Panos auch der Browser aufhängt, wenn man in fullscreen umschaltet (dürfte bei geringeren Auflösungen seltener auftreten) - ich hab dazu von Klaus "ruckzuck" gerade ein bugfix erhalten...

Grüße,
Oliver
best regards from www.PanAustria.com

8

Saturday, June 6th 2009, 12:21am

ohh, ja hängt sich bei mir auch auf (Firefox 3.0.10 auf Mac OSX 10.5.7)
Der Bugfix würde mich interessieren :)

Gruß Marc

VN2009

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

9

Saturday, June 6th 2009, 12:55am

[url]http://babelfish.yahoo.com/translate_url?doit=done&tt=url&intl=1&fr=bf-home&trurl=http%3A%2F%2Fwww.krpano.com%2Fforum%2Fwbb%2Findex.php%3Fpage%3DThread%26threadID%3D796%26highlight%3D&lp=de_en&btnTrUrl=Translate[/url]

for the german challenged people like me this is what they are saying :)

10

Saturday, June 6th 2009, 8:49am

to marc:
here you find the link to the bugfix, it solved my problems immediately!

to babel fishing people:
we first talked about finding a way for switching off the loading bar after an initial show up, eg after loading preview or after a first loading sequence of multires panos. Klaus told us this is possible now with the latest beta...
then exchanged our first bug experience (new release) - firefox and safari sometimes run into a memory overflow on switching to fullscreen (more often on higher res panos). Here is my thread about it in english.

btw: I read what babelfish did for you and - surprise - not so bad! Could you understand its translations? - but i hope the english translated by my own "babelbrabelbrain" is better...
best regards from www.PanAustria.com