You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Daniel25

Beginner

  • "Daniel25" started this thread

Posts: 20

Location: london

Occupation: photographer

  • Send private message

1

Thursday, September 27th 2012, 6:42pm

Problems with auto rotate

Hi everyone It may sound silly but since I have downloaded the new version of Krpano the autorotate is giving me some problems.... *cursing*

Before I use to have a very smooth effect but now it is always a bit fragmented,
Does anyone know why, I really need a solution pretty urgently as my client is waiting for some virtual tours.

Here belowe is the autorotate function I use.

Many thanks

Daniel



<autorotate enabled="true"
waittime="1"
accel="1"
speed="4.0"
horizon="0.0"
/>

2

Friday, September 28th 2012, 1:20pm

Hi,

nothing else has changed?
Browser? Flashplayer?

There autorotate function itself should work like in all previous versions, there were no changes here...

best regards,
Klaus

Daniel25

Beginner

  • "Daniel25" started this thread

Posts: 20

Location: london

Occupation: photographer

  • Send private message

3

Tuesday, October 2nd 2012, 7:00pm

Hi Klaus that is strange...... have you ever encounter such problem before?

I will try making some more and see how they come, and I will let you know.

Many thanks! was the code I wrote right?

4

Saturday, October 6th 2012, 4:51pm

Hi,

yes, the code itself is right of course,
but without knowing what has changed in your case, it's not possible to recommend or to direct to something...
the autorotate function itself has not changed...

best regards,
Klaus

5

Wednesday, November 7th 2012, 10:14am

My customer has been complaining about this for some time about the autorotate that it is not smooth. I have the following code:

<autorotate enabled ="true"
waittime="1.5"
accel ="1"
speed ="7"
horizon ="off"
tofov ="NaN"
/>

The only thing that I changed from the previous is the screen size. Once I make it to full (100%) or fullscreen, the jerky motion is more predominant. In a smaller screen, the motion is quite smooth. Is there any correlation?

Here is a pano for reference:
http://www.fotobubbles.com/tours/agra/hotelclarksshiraz/

6

Wednesday, November 7th 2012, 11:22am

Hi,
The only thing that I changed from the previous is the screen size. Once I make it to full (100%) or fullscreen, the jerky motion is more predominant. In a smaller screen, the motion is quite smooth. Is there any correlation?
Of course there is a correlation!
Larger screen size = more pixels on the screen = more pixels to calculate = more CPU power is needed

Btw - this setting in your html, also can reduce the performance a lot:

Source code

1
viewer.addParam("wmode", "transparent");


See here for more details:
http://krpano.com/docu/html/#wmode

Best regards,
Klaus

7

Wednesday, November 7th 2012, 11:32am

Thanks for the reply Klaus!

Also, I am using display parameters as follows:


<display fps="60"
details="16"
tessmode="-1"
movequality="BEST"
stillquality="BEST"
flash10="on"
movequality10="BEST"
stillquality10="BEST"
stilltime="0.1"
showpolys="false"
/>

Do we need to tweak these to make it more smoother?

8

Wednesday, November 7th 2012, 11:50am

Hi,

as most important setting - change the wmode setting back to 'window' or remove it totally from the html!

About the display settings - using HIGH instead of BEST can also improve the performance a bit and there should be no visual difference.

Best regards,
Klaus

9

Wednesday, November 7th 2012, 11:53am

Thank you Klaus. I will check and see.