You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, September 30th 2012, 9:10pm

How to load image gallery into a tour

I'm sorry I keep coming back to this, if it can't be done then okay.

here is a screen shot of a gallery as a standalone.


Gotten further, loading xml instead of calling a scene, 2 issues now, it says loading on the scree even after the thumbar has been created and the pictures just load over the word loading.

second issue, when I click on the tour map I error out with "loadscene() = scene "scene_floorplan" not found. I thought the merge and blend was to keep everything loaded.



I'm calling it from a hotspot on the tour map.


<hotspot name="spot305" url="skin/vtourskin_mapspotactive.gif" scale="0.25" ath="0.291" atv="0.065" onhover="showtext(1931 American Austin Image Gallery)" onclick="loadpano(images/31americanaustin/imagegallery2.xml,null, MERGE, BLEND(1));" />


here is the gallery code.

<krpano onstart="start();">

<!-- I like the grid cube -->
<preview type="grid(cube,2,1,256,0x000000,0x000000,0x222222);" details="16" />

<!-- include image thumbbar xml script code -->
<include url="../plugins/thumbbar.xml" />

<action name="start">

create_thumbbar(5, right, v, 10,10, 90,60, 6);

thumbbar_addimage('images/KA_001.jpg');
thumbbar_addimage('images/KA_322.jpg');
thumbbar_addimage('images/KA_323.jpg');
thumbbar_addimage('images/KA_324.jpg');
thumbbar_addimage('images/KA_321.jpg');
</action>

</krpano>

okay, I got rid of the loading message by adding the resetkrpano action and changing the hotspot to

<hotspot name="spot305" url="skin/vtourskin_mapspotactive.gif" scale="0.25" ath="0.291" atv="0.065" onhover="showtext(1931 American Austin Image Gallery)" onclick="resetkrpano();loadpano(images/31americanaustin/imagegallery2.xml, nul, MERGE, BLEND(1));" />

I get the same error with the addition of the warning unknown action hideintro image



So what am I doing wrong?
Bill


http://rhmpano.com Panoramas and gigapixel images
http://astimegoesby.us Personal family history back to the 1800's

This post has been edited 4 times, last edit by "billjones" (Oct 1st 2012, 4:01am)